GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 3 FirstFirst 123 Last Post byLast Post by
Results 11 to 20 of 22
  1. #11

    Default

    Quote Originally Posted by Z71_guy View Post
    i would have to say the sending unit is bad, but as stated earlier its part of the pump assembly
    X2- I agree the sending unit is bad. Change the pump and that should fix it.

    Jim
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  2. #12

    Default

    My 99 has been doing the same thing for the past 20k. It starts and empty and bounces back and forth, or slowly comes up to the correct reading. Its worst when the tank is near empty or near full. I just use my trip odometer and refill every 250 miles... it gives me an excuse to religiously track my gas mileage as well. Pump hasn't started whining either... Not worth fixing in my opinion until the pump is on the outs.

  3. #13

    Default

    Ok....I did some digging on the web and found that there is an existing Technical Service Bulletin (TSB) issued by GM. I can only find the summary description, nothing more.

    I'm sure it applies to other models and years as well....

    Anyone know how I can get the complete TSB for this?

    It appears that GM knows very well the issues around this problem.....

    Make : CHEVROLET
    Model : SILVERADO
    Year : 2000
    Manufacturer : GENERAL MOTORS CORP.
    Service Bulletin Number : 3046A
    NHTSA Item Number : 10009382
    Component : FUEL SYSTEM, OTHER:STORAGE:FUEL GAUGE SYSTEM
    Last edited by iceman68; 03-23-2009 at 11:13 AM.
    Elan Imseis

    2000 Silverado
    1968 Camaro


  4. #14
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,390

    Default

    I would call the nearest chevy dealership, give them your VIN and they can check it for you.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  5. #15

    Default

    ive got the same problem in my truck. i dont have any strange noises or anything, i've just kind of chalked it up to wiring, the guy i bought the truck off of said it started happening after he had the command start installed. its never been a big deal, just got keep an eye on my trip mileage so i dont run er dry.
    1999 silverado Z71
    5% tint
    cherry bomb glasspack
    K&N intake
    2 12" kicker CVR's
    custom painted emblem
    32" BFG All Terrains

  6. #16

    Default

    I just replaced the fuel pump and sending unit in my 1999 k2500 today, in an effort to fix the gas gauge, gas gauge is still not working. Turn on the switch fuel level reads gas level in the tank for about 2 seconds then the neddle drops below empty and sets there and vibrates.

  7. #17

    Default

    My fuel pump officially went last Wednesday morning....Had it replaced and the fuel guage is working fine now.

  8. #18
    Sr. Apprentice kaiah723's Avatar
    Join Date
    Jan 2009
    Location
    Bridgeport, CT
    Posts
    63

    Default

    Quote Originally Posted by iceman68 View Post
    My fuel pump officially went last Wednesday morning....Had it replaced and the fuel guage is working fine now.
    glad to here everything is working good
    2009 cobalt ss, imperial blu metallic, lsd, dejon powerhouse intake, Dejon bpv spring upgrade, Trifecta tune, clutchmasters aluminum flywheel, clutchmasters stage 1 clutch, 20% tints,

    2008 avalanche ltz, imperial blue metalic, k&n cold air intake, Gibson cat back duel exhaust

  9. #19
    Sr. Apprentice kaiah723's Avatar
    Join Date
    Jan 2009
    Location
    Bridgeport, CT
    Posts
    63

    Default

    Quote Originally Posted by shantie View Post
    I just replaced the fuel pump and sending unit in my 1999 k2500 today, in an effort to fix the gas gauge, gas gauge is still not working. Turn on the switch fuel level reads gas level in the tank for about 2 seconds then the neddle drops below empty and sets there and vibrates.

    did u replace the pump and sending unit or did a garage do it?

  10. #20

    Default fuek gauge

    Ireplaced the fuel pump and sending unit assembly, for the 1999 Chevy trucks it is the only way that you can purchase the sending unit. I checked the voltages at the connection they seem to be ok.

    Which leads me to the fuel gage in the instrument cluster. can you purchase just the fuel gauge or do you have to replace the whole instrument cluster. If so is there an after market gauge that I can purchase, I just don't want to run out of gas.

Similar Threads

  1. Gas Guage
    By JonZ71 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 05-11-2010, 02:44 AM
  2. Fuel Guage
    By Tenmore in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 11-26-2009, 02:58 AM
  3. 01 sierra fuel guage issues
    By chola in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 13
    Last: 07-21-2009, 01:50 PM
  4. Fuel Guage
    By matzner66 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 01-28-2009, 10:59 PM
  5. fuel guage
    By rexdavisson in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 06-02-2008, 08:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •