GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6

Thread: Rough Idle..

  1. #1

    Default Rough Idle..

    I got a rebuilt 5.7 engine put in my 96 suburban 2yrs ago as my original 5.7 which i thought died on me at 200,000miles(long story but the mechanic was wrong about needing a new engine) and at first the engine ran fine at idle, i had constant oil leaks that the mechanic shop did not want to fix and after the last trip to the mechanic shop(my last time to take it back to where i got the engine) i got the suburban back and since then has a rough idle at 700rpms, you can feel it throughout the vehicle that it is idling rough and you can feel the vibration. Ive taken it to the dealership to get it looked at and found out it had autolite spark plugs in it so i changed those out with the recommended delco plugs. The spark plug wiring is the premium plug wires from napa that have the lifetime warranty. The distributor cap was replaced as well. What I think it is, is a possible vacuum leak somewhere, for when i have it in gear the idle drops back down to the default idle of 550? When it is in park or neutral it goes straight back to idling rough at 700rpm. The dealership could not figure out what was causing the rough idle as they could not find anything wrong. the rough idle started right after the mechanic at the shop i got the engine thought my intake manifold was leaking but then found it was leaking elsewhere, i think he might have forgotten or messed up a vacuum seal somewhere possibly?

    Any help would be greatly appreciated as I am clueless on this other than a possible vacuum leak but i dont know where to start for that and how to check intake manifold. The mechanic at the shop did not replace any of the belt pulleys and the belt tensioner and idle pulley have never been replaced. All of the pulleys are original parts.
    Last edited by willbradfan; 03-18-2009 at 10:56 PM.

  2. #2

    Default

    It sounds like it may be a timing issue. Have you checked the ignition timing? It could also be the cam timing that's off too.

    Someone on this forum suggested using a smoke machine to find vacuum leaks. You may want to look into that if you're convinced it's a vacuum leak. Those can be a real PITA to find.
    Scott

    ΜΟΛΩΝ ΛΑΒΕ

    '94 Chevy Suburban K1500
    3" exhaust w/ aero turbine non-baffled muffler
    CFM Technologies TB spacer
    CB w/ 44" whip antenna


  3. #3

    Default

    When engine was put in, the camshaft sensor was not replaced with a new one. I am not sure if that would make difference or not but it would seem that it would. The dealership installed the spark plugs for me and after doing that they checked the timing and did not see anything wrong with it, so it seemed okay except for the rough idle.

  4. #4

    Default

    I also had a short somewhere in the wiring for some sensors and had to rewire the power for the sensors customly, could that have possibly messed the camshaft sensor up?

  5. #5
    Jr. Mechanic
    Join Date
    Dec 2008
    Location
    Gettysburg, Pa.
    Posts
    103

    Default rough idle

    It wouldn't hurt to pull the plugs and check the gaps yourself for peace of mind . On the "custom" rewiring for the sensors is there any hand splices or crimp splices because many sensors rely on millivolt readings and simple splices are not recommended, they should be soldered so they are as electrically conductive as the original wire.

  6. #6

    Default

    All of the rewiring for the the two sensors which are the mass airflow sensor and the camshaft sensor were spliced and crimped together, sorry about reviving this haha but today I was sitting in my truck for a while and then started holding down several window switches and the rpms dropped and i could feel the idle just smooth out when it was in park and the volt meter went down as well, could this possibly be coming from something that is pulling an extra amount of power from the battery thus the computer is running the idle higher to keep up with the amount of energy being pulled from the battery?
    K1500 5.7L Chevy Suburban
    290000+ miles
    K&N CAI
    Black Bear Performance Tune
    TCI Servo and Shift Kit
    Long Tube Ceramic Pacesetter Headers
    Custom Side Swept Dual Exhaust
    Dual 2.5in electric DMH Performance Exhaust Cutouts
    BFG A/T 285s

Similar Threads

  1. Rough Idle in Chevy Colorado Pickup
    By lilmissme in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 3
    Last: 07-09-2011, 02:19 PM
  2. rough idle 4.3 v-6
    By RATRODKING in forum GM Powertrain
    Replies: 19
    Last: 05-03-2010, 03:21 AM
  3. rough idle with a/c
    By willardearl76 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 04-07-2010, 09:38 AM
  4. rough idle
    By niteruner in forum Chevy Colorado Forum (GMC Canyon)
    Replies: 0
    Last: 12-09-2007, 07:12 PM
  5. rough idle
    By L0sts0ul in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 02-25-2007, 07:38 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •