GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default Windshield Washer Fluid Pump

    The Short Version: I'm trying to locate the pump for the windshield washer fluid. Does anyone have a diagram or pic of it?


    The Long Version:

    My "Check washer fluid" note was showing on the dash, so I thought great! I have a whole bottle of juice in the garage. I poured it into the resevoir, and almost immediately it was pouring out onto the driveway.

    So after a little searching I found out that there was a break/crack in the a line coming from the reservoir. Doing a little more research it turned out that it was actually disconnected from the line that goes to the wipers. I also noticed that the one going to the rear window was also broken.

    I marched to AutoZone and got some replacement hose, the rubber kind, which just about fit perfectly over the original more firm kind. I joked to the lady, that "I'd get this fixed just to find out that the pump wasn't working..." (I'd not tested that part since I picked up the truck last week).

    So I come home, repair the lines put the battery back in and give it a whirl... Sure enough... no juice is flowing... Guess I jinxed myself with that comment. The good news however, there isn't a leak anymore and the rear washer is working just fine!

    This brings me to today... and my question... Where is the front fluid pump? cause well, I guess that is what I need to look at next. The switch in the cab appears to work fine, the wipers move when the washer is pressed, I just don't hear any pump motor.


    thanks in advance!

    -matt-
    ---------------------------------------------------------------
    2003 K2500 Sububan 6.0L w/Quadrasteer
    190,000 + miles

    ---------------------------------------------------------------

  2. #2

    Default

    my bad just woke up i'll fix it in a sec
    Last edited by scgamer_99; 03-23-2009 at 12:03 PM.

  3. #3

    Default

    That looks to be the wiper motor guide...

    I'm looking for the fluid pump

    -matt-
    ---------------------------------------------------------------
    2003 K2500 Sububan 6.0L w/Quadrasteer
    190,000 + miles

    ---------------------------------------------------------------

  4. #4
    Moderator
    dwill3015's Avatar
    Join Date
    Jan 2007
    Location
    Yacolt, Washington
    Posts
    4,338
    Blog Entries
    2

    Default

    Use the repair manuals online link in the tech Q&A. I just looked it up for your 03.
    Darcy
    Washington State
    2006 Silverado 2500HD LT3 4X4 CC SB Duramax LBZ
    Tuff Country 6" lift, 35" Toyo M/T's on 20" Ultra Peacemaker wheels, Quadzilla Stealth2 programmer, Diamond Eye 5" cat-back exhaust, factory Special order color Yellow.

  5. #5

    Default

    Quote Originally Posted by meash20 View Post
    The Short Version: I'm trying to locate the pump for the windshield washer fluid. Does anyone have a diagram or pic of it?


    The Long Version:

    My "Check washer fluid" note was showing on the dash, so I thought great! I have a whole bottle of juice in the garage. I poured it into the resevoir, and almost immediately it was pouring out onto the driveway.

    So after a little searching I found out that there was a break/crack in the a line coming from the reservoir. Doing a little more research it turned out that it was actually disconnected from the line that goes to the wipers. I also noticed that the one going to the rear window was also broken.

    I marched to AutoZone and got some replacement hose, the rubber kind, which just about fit perfectly over the original more firm kind. I joked to the lady, that "I'd get this fixed just to find out that the pump wasn't working..." (I'd not tested that part since I picked up the truck last week).

    So I come home, repair the lines put the battery back in and give it a whirl... Sure enough... no juice is flowing... Guess I jinxed myself with that comment. The good news however, there isn't a leak anymore and the rear washer is working just fine!

    This brings me to today... and my question... Where is the front fluid pump? cause well, I guess that is what I need to look at next. The switch in the cab appears to work fine, the wipers move when the washer is pressed, I just don't hear any pump motor.


    thanks in advance!

    -matt-
    Check out Autozone again for the pump itself, and ask if they can print out the replacement instructions for the part. That should locate it for you, but on earlier versions it is on the resovoir
    If you wake up, Its a good day!:great:

  6. #6

    Default

    its on the reservoir

    2003 Z71 Silverado LS
    Access roll up cover
    Bed Rails
    Billet Grill insert
    Bed Rug
    CB with PA system
    Waiting to be installed
    Two 8in RF HX2 punch( would have 12s but they got stolen)

  7. #7

    Default

    Quote Originally Posted by Z71_guy View Post
    its on the reservoir
    Thanks!

    Figured as much... haven't taken the time to get down to it just yet...

    -matt-
    ---------------------------------------------------------------
    2003 K2500 Sububan 6.0L w/Quadrasteer
    190,000 + miles

    ---------------------------------------------------------------

  8. #8

    Default

    Quote Originally Posted by meash20 View Post
    The Short Version: I'm trying to locate the pump for the windshield washer fluid. Does anyone have a diagram or pic of it?


    The Long Version:

    My "Check washer fluid" note was showing on the dash, so I thought great! I have a whole bottle of juice in the garage. I poured it into the resevoir, and almost immediately it was pouring out onto the driveway.

    So after a little searching I found out that there was a break/crack in the a line coming from the reservoir. Doing a little more research it turned out that it was actually disconnected from the line that goes to the wipers. I also noticed that the one going to the rear window was also broken.

    I marched to AutoZone and got some replacement hose, the rubber kind, which just about fit perfectly over the original more firm kind. I joked to the lady, that "I'd get this fixed just to find out that the pump wasn't working..." (I'd not tested that part since I picked up the truck last week).

    So I come home, repair the lines put the battery back in and give it a whirl... Sure enough... no juice is flowing... Guess I jinxed myself with that comment. The good news however, there isn't a leak anymore and the rear washer is working just fine!

    This brings me to today... and my question... Where is the front fluid pump? cause well, I guess that is what I need to look at next. The switch in the cab appears to work fine, the wipers move when the washer is pressed, I just don't hear any pump motor.


    thanks in advance!

    -matt-
    Just had the exact same thing happen. Best I can figure it's coming out of the pump that sits on the reservoir so ordered a new pump. Did you replace yours? Seems difficult to get to so looking for any advice on how to get it off and replaced.
    Thanks,

  9. #9

    Default

    Just repaired a crack in the resevoir on my 2000 burban. Pulled the battery and battery pan, took the screws out of the reservoir and pulled it out from under the vehicle. The pumps and electric are "plugged" into the bottom of the reservoir. My 2 cents - for what it's worth.

Similar Threads

  1. Windshield Washer Pump not working (not the pump)
    By vdubn in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 11-20-2010, 09:39 PM
  2. Windshield Washer Fluid Rain-X Bug Remover review
    By Dr_Zero in forum Product Reviews
    Replies: 20
    Last Post: 04-07-2010, 09:05 AM
  3. Windshield washer pump
    By truck3 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 6
    Last Post: 03-12-2009, 05:13 PM
  4. Windshield Washer Fluid System
    By SilveradoBrett in forum General Chevy & GM Tech Questions
    Replies: 12
    Last Post: 12-08-2008, 06:34 AM
  5. Windshield washer pump
    By truck3 in forum Chevy C/K Truck Forum
    Replies: 1
    Last Post: 01-19-2008, 12:18 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •