GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default replaced HU still doesnt work HELP

    I have a 2004 Chevy [COLOR=blue ! important][COLOR=blue ! important]Suburban[/COLOR][/COLOR] fully loaded with the bose system. About 2 weeks ago the stereo was acting up and if you would crank the bass there wouldnt be any at all. It did this for about a week and then randomly there was no sound output at all. If you turn everything up there is still no sound. I checked the amp and stereo fuses and they are fine. Also when you turn on the rear stereo controls every speaker in the [COLOR=blue ! important][COLOR=blue ! important]car[/COLOR][/COLOR] pop very loud. I replaced the HU with the same kind from my friends 03 H2 and the speaekers will randomly pop without the key in the ignition and the stereo says lock. Can i use the HU from the hummer and just have it reset or what. the H2 HU is part #15198715 and the REM# is 12229245
    Please help me

  2. #2

    Default

    sry to hear about you radio i am not sure if you can use te hummer one or not the easy way is et an after maket or one from a junk yard that still works

    2004 1500 silverado z71
    3inch lift 33inch bfg at ta ko
    flowmaster eghaust intake
    smoke third brake light and tail light
    15% tint on front windows
    and system
    BLACK
    BEAUTY
    Z71

  3. #3

    Default

    yeah thats what i thought but then i would loose rear stereo controls and the dvd controls. thats what happened in my old expolder

  4. #4

    Default

    I know hey have some sort of anti theft mechanism which is probably why it says lock. Sorry I'm not more knowledgable but I hope this points you in the right direction.
    2000 Silverado ext cab1500 Z71
    Have:
    -K&N
    -SPR-17S Fronts with 100RMS watts to each
    -Billet Grill
    -Bedliner
    -Catback Flowmaster Exhaust
    -CDA-9884 Head unit w/ iPod hookup
    -2 KFC-W3011 subs (seperate boxes 1 cu ft air space each) powered by a KAC-9104D 900 watt RMS monoblock amp
    -SPR-57C rear speakers
    -Door dings
    -Leveling kit (2.5" torsion keys)

    Want:
    -6" Suspension Lift
    -35" tires (maybe 38s)
    -HID/projector headlights
    -Headers
    -Programmer/Tuner

Similar Threads

  1. brake lites work blinker doesnt
    By mad_hungarian in forum Audio, Video & Gadget Tech
    Replies: 5
    Last Post: 09-11-2009, 06:56 PM
  2. Drive doesnt work but '1', '2' and '3' do
    By kiknit in forum GM Powertrain
    Replies: 4
    Last Post: 08-24-2009, 08:45 AM
  3. 05 Chevy Silverado Oil temp gauge doesnt work right.
    By beerguy25 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 03-10-2009, 10:47 PM
  4. turning signal doesnt work with headlights on
    By haus01 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 12-30-2008, 07:27 PM
  5. Air ride suspension..doesnt work
    By Gregg in ohio in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 1
    Last Post: 05-06-2007, 10:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •