GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    Question Problem with headunit

    Well i got a problem with installing an aftermarket head unit, well since i have an 02 suburban with out the bose system but with onstar, when i installed the radio, no sound came out? sombody told me that i needed the onstar bypass, do i have to get it? or can i tottally remove onstar since i dont use it???

  2. #2

    Default

    I just installed a head unit i n my 06 and when I got my wiring harness I was asked if I had onstar, I was told that there are like three wirning harness' for the GM trucks. One for onstar one with the door buzzer and one without anything. I had to pay like $70 for mine with the door and seat belt chime. And it's louder than the factory chime. I'm not sure about remove the onstar I've never heard anyone doing that. Good Luck.
    2006 Silverado Crew Cab, stock for now.
    Plans on lowering and stereo, rims

  3. #3

    Default

    So there is no way of using an aftermarket head unit with out buying that onstar bypass? i thought that was only if you wanted to keep onstar using an aftermarket head unit?

  4. #4

    Default

    yea there is 2 dif harrnesses one with onstar and the other with out but that chime crap is irratating as hell you were lucky with the 70 dollar harrnes every where i went it was 80 plus tax

  5. #5

    Default

    STOP!

    here's what you do: there are TWO harnesses that plug into the factory radio. one of them is the conventional GM plug that has power / antenna / speaker connections...and the other is a tiny connector with like 4 or 5 wires in it. in the tiny connector with 4 or 5 wires, there is a pink wire. if you run the blue/white remote output of the head unit (or the RED wire if there's no blue/white) into the PINK wire of this harness, your sound system will fire up. this is the factory amplifier turn-on wire. i've saved people bookoo bucks doing it this way tons of times.

  6. #6

    Default

    Aww man Thanks A bunch.... it really helped.

  7. #7

    Default similar head unit problem in 02' Tahoe

    Quote Originally Posted by nhenson1 View Post
    STOP!

    here's what you do: there are TWO harnesses that plug into the factory radio. one of them is the conventional GM plug that has power / antenna / speaker connections...and the other is a tiny connector with like 4 or 5 wires in it. in the tiny connector with 4 or 5 wires, there is a pink wire. if you run the blue/white remote output of the head unit (or the RED wire if there's no blue/white) into the PINK wire of this harness, your sound system will fire up. this is the factory amplifier turn-on wire. i've saved people bookoo bucks doing it this way tons of times.
    I installed my Pioneer DEH-p3000IB head unit into my 02 Tahoe and it will turn on and light up like it's working but there will be no sound from my speakers. Sometimes if I turn my electricity on it will come on, but if I turn the car all the way on it will still act like its working fine, but with no sound. It will work fine sometimes but most of the time it doesn't put out sound. The people at BestBuy said to buy like a 70 dollar wiring harness for it to be able to work with the OnStar, but I'll probably try your method first. Any more advice?

  8. #8
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,356

    Default

    Dont buy car audio from Best Buy, it is expensive and the product the sell for harnesses is JUNK! Cant remember the name for sure its like Dynex I think.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  9. #9

    Default did that work?

    Quote Originally Posted by crazyguy View Post
    Aww man Thanks A bunch.... it really helped.
    Did the advice that guy gave you about running the white/blue wire into the pink wire work? because I have the same problem in my 02' Tahoe

  10. #10

    Default

    If there is a wiring from remote out to pink wire works, this is the best way. If i am not mistaken, the 02 gm trucks have the non-upgradeable analog onstar that you cant use now if you wanted to. So my view, although i do not have onstar is thisL

    why pay for a harness to retain a feature I couldn't use if i wanted to?

    does that concept seem a bit weird to anyone else?

    2001 Silverado Reg. Cab Not-So-Base -- SOLD
    2003 Avalanche Z71. No Cladding. Check out my Mod thread.
    1974 Triumph Spitfire 1500 - Work in Progress
    2003 Sierra 3500 Duramax. The Newer, Better Work Truck


Page 1 of 2 12 LastLast

Similar Threads

  1. New Headunit or Amplifier
    By emtJoaquin in forum Audio, Video & Gadget Tech
    Replies: 5
    Last Post: 09-07-2009, 10:41 AM
  2. DID Headunit
    By chevycamarado in forum Audio, Video & Gadget Tech
    Replies: 0
    Last Post: 09-06-2009, 12:58 PM
  3. 08 silverado new headunit problem????
    By WatsonGravy in forum Audio, Video & Gadget Tech
    Replies: 1
    Last Post: 03-05-2009, 01:01 PM
  4. 08 silverado Headunit Help
    By dougger in forum Audio, Video & Gadget Tech
    Replies: 2
    Last Post: 02-05-2009, 10:10 AM
  5. Kenwood Headunit Installed
    By MD4x4 Fireman in forum Audio, Video & Gadget Tech
    Replies: 9
    Last Post: 10-06-2007, 10:13 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •