GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Help Please! - Speedometer Not Working

    Okay, my problem is simple. My speedomer isn't working.

    Basically, every since the other night it has been pegged on 100, and will not move. I beleive that it got shorted out while I was messing with some wires going through the firewall.

    I've tried looking for a fuse for the speedometer to see if it was blown, but could never find one that was for the speedometer.

    Maybe something came lose? Not sure.

    By the way, this is a 1999 Chevy Silverado Z71, new body style. All other guages work on the dash... except for the speedometer which is pegged at 100.

    Like I said, I'm figuring that I shorted it out the other day when I was messing with the cables -- though I couldn't find a fuse for the speedometer.

    Any wiring diagrams, or advice on how to fix this would be much appreciated.

    Please advise...

  2. #2

    Default

    I had a similar problem in my 2000 S-10, which I no longer have, but it ended up being the fuse for the radio...I know that sounds weird but that fuse was blown, and after replacing it the speedo worked fine. Hope this helps.

Similar Threads

  1. Replies: 7
    Last: 12-20-2010, 01:20 PM
  2. Replies: 5
    Last: 09-12-2009, 06:23 PM
  3. speedometer ain't working.
    By chevy_fan in forum Audio, Video & Gadget Tech
    Replies: 7
    Last: 01-01-2009, 08:36 PM
  4. Speedometer not working
    By dustin88 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-15-2008, 12:39 AM
  5. Speedometer
    By EagleTalons in forum Chevy C/K Truck Forum
    Replies: 5
    Last: 12-13-2008, 02:07 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •