GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Transmission problems

    I bought my truck from a GM dealer in October. It has run flawless everyday until about 2 weeks ago. The transmission started acting up. Some examples. Like today I started it and I let it run for a few minutes and then put it in reverse and I barely had my foot on the gas and it started to like Whind up for a few seconds and then the truck kind of jerked and then it started driving fine. Lately when I take off it will shift from 1st to 2nd extremely hard and then after that it shifts smooth. So does anyone have any ideas? Its a 2006 Chevy Silverado 1500 2wd automatic with tow mode. Im taking it to my friends transmission shop tomorrow and hes going to see if theres anything wrong with it and put some new fluid in it.
    Bagged 06 Silverado Crew Cab.

  2. #2

    Default

    Quote Originally Posted by ZSI52 View Post
    I bought my truck from a GM dealer in October. It has run flawless everyday until about 2 weeks ago. The transmission started acting up. Some examples. Like today I started it and I let it run for a few minutes and then put it in reverse and I barely had my foot on the gas and it started to like Whind up for a few seconds and then the truck kind of jerked and then it started driving fine. Lately when I take off it will shift from 1st to 2nd extremely hard and then after that it shifts smooth. So does anyone have any ideas? Its a 2006 Chevy Silverado 1500 2wd automatic with tow mode. Im taking it to my friends transmission shop tomorrow and hes going to see if theres anything wrong with it and put some new fluid in it.
    Zack,

    Your transmission is either low on oil or the filter is starting to clog up with debris. Did you check the oil with the engine running? If the oil level is OK then you need to get it into the shop pronto.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    Thanks for the reply. I checked all the fluids several times. I checked the fluid while it was running . They all look good. I'm at my friends transmission shop right now. So I guess we will hopefully find out what's wrong with it.
    Bagged 06 Silverado Crew Cab.

  4. #4

    Default

    Just got back. Seems to be working great now. Thanks for the reply.
    Bagged 06 Silverado Crew Cab.

Similar Threads

  1. Transmission Problems, Maybe
    By Davidss in forum GM Powertrain
    Replies: 5
    Last Post: 04-17-2010, 08:49 PM
  2. transmission problems in your GM?
    By Steve in forum GM Powertrain
    Replies: 12
    Last Post: 07-07-2007, 10:44 PM
  3. Trailblazer Transmission Problems
    By Steve in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 4
    Last Post: 03-31-2007, 11:48 AM
  4. Transmission problems [Expired Topic]
    By Rave04 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 12
    Last Post: 11-14-2006, 04:13 PM
  5. Transmission Problems
    By Stauter99 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 0
    Last Post: 08-21-2006, 11:41 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •