GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1
    Sr. Apprentice lube70's Avatar
    Join Date
    Jan 2009
    Location
    Northern NJ
    Posts
    48

    Exclamation My trans blew up!!!

    I have a 06 Silverado Crew cab 1500 and was driving to a jobsite (actually the New Giants Stadium) and heard a "boom" and then nothing in drive or over-drive.

    Contacted chevrolet who told me and I quote "this happens all the time with the Avalanche and sometimes on the Silverado, bring it in".

    Bring it in and they tell me the forward sprag gear went and I'd have the truck back the same day!!!

    Anyway, I have done trannys and engines a long time and know that once a part goes, most start to follow. The over-run clutches were worn also so they were replaced. Asked for a new trans and they said it was not cost effective!!!

    So, now I have a supposedly good trans, and a cloud over me waiting for the next "boom".

    ANyway, any one ever hear of this happening...Forward sprag thing????

    Thanks in advance for the replies!!!

    Don
    2006 Chevy Silverado crew cab 1500

  2. #2

    Default

    Kind of off topic but did you notice anything wrong before it happend? I think my transmission might be getting ready to go out.
    Bagged 06 Silverado Crew Cab.

  3. #3

    Default

    well the Sprag is a Clutch that allows the transmission to smoothly shift into other gears, i guess thats why it would not go any where.


    1995 Chevy Silverado
    Fully loaded!!!
    4Wheel Drive
    5.7 Liter
    Blue
    Best Engine In The World!!!!!
    Once i had a nearly dead battery and was only able to get 1 slow crank per attempt, Once to the fifth crank she fired up! (True Story)
    ________________________________________
    Do you have a Tahoe,Yukon or a suburban? Join My Group
    http://www.gmtruckclub.com/forum/group.php?groupid=26

  4. #4

    Default

    Don,

    The sprag failure is fairly common and it may have to do with a bad batch of sprags. I wouldn't be worried about it. The over run clutch plates always get burned when the sprag fails. The dealer installed an updated sprag so you should be good to go.
    Keep in mind that any time you put your transmission into gear the input sprag is what's linking the engine through the torque converter to your transmission. So any kind of abuse like rocking the truck in the mud or snow from D to R to D as well as selecting D with a high idle puts an extra load on the input sprag clutch.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  5. #5
    Sr. Apprentice lube70's Avatar
    Join Date
    Jan 2009
    Location
    Northern NJ
    Posts
    48

    Default thanks for the info

    To answer a few questions...

    Yes, noticed that it slightly shifted harder 1 to 2 gear...

    In reverse, you would have to wait a second or it would BANG into reverse .


    The trans otherwise was fine to what I was told.


    Guess I'll wait and see....

    Don

  6. #6

    Default

    Quote Originally Posted by lube70 View Post
    To answer a few questions...

    Yes, noticed that it slightly shifted harder 1 to 2 gear...

    In reverse, you would have to wait a second or it would BANG into reverse .


    The trans otherwise was fine to what I was told.


    Guess I'll wait and see....

    Don
    Mine is doing the same thing. Im taking mine to GM monday.

  7. #7

    Default

    That happened to my buddy he has an 06 with 26K on it he was on rt 80 not far from Giant Stadium he just gave it some gas to pass some one and THUD...
    2003 Silverado Z71 Ext Cab 100K

Similar Threads

  1. i think my motor just blew:s
    By kawasaki_kid in forum General Chevy & GM Tech Questions
    Replies: 36
    Last: 12-30-2013, 06:44 AM
  2. blew the rear
    By shagginwagon in forum Lifted & Offroad Suspension
    Replies: 4
    Last: 07-19-2010, 02:29 AM
  3. Blew my summer budget today...
    By pmf608 in forum General Chevy & GM Tech Questions
    Replies: 3
    Last: 08-08-2009, 11:24 PM
  4. blew my 4X10.... in my 92 sonoma.. where can I get something?
    By Falcone in forum Audio, Video & Gadget Tech
    Replies: 1
    Last: 08-06-2009, 07:24 PM
  5. my engine blew (sigh)
    By scgamer_99 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 03-23-2009, 10:44 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •