GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Hybrid View

  1. #1

    Default Heater blower relay

    1990 Suburban 4x4 1/2 tonne. 350

    Hi.

    I'm pretty sure I need a new heater blower relay, but wanted to run it by someone else (who knows more than me) before buying one.

    The facts :

    When I switch the heater on from inside, the blower motor does nothing.
    When I run a hot wire from the battery to the blower motor, it fires up.
    I'm getting 12v at the red wire that goes into the relay.
    I'm getting less than 1v coming out of the purple wire from the relay that plugs into the blower motor ....

    What do you think? Relay? or something else that I've missed?

    Thanks,

    Ross.

  2. #2
    Jr. Mechanic SoundZman's Avatar
    Join Date
    Apr 2009
    Location
    Santa Clarita, CA
    Posts
    106

    Default

    Sounds pretty straight forward to me...shot relay. Great job on testing the blower motor first. The funny thing is, your getting 1v to the motor...what happens when you put 1 lead on the purple and another on a good ground source?

    Usually when a relay goes it's the coil that fails therefore you should just have an open (or closed) circuit depending on the NO or NC design. The fact that your seeing some type of bleeding voltage probably mean that either the relay burnt up pretty bad or that circuit has a flaky ground...sounds like bad relay due to a good +12v fires up the motor.
    >>>2003 Suburban K1500 LT<<<

    Currently:
    ~Rear overhead DVD
    ~Orion 600D
    ~ 12" Acoustic Elegance AV12
    ~Hankook ATM DynPro A/T's
    ~Flowmaster exhaust

  3. #3

    Default

    Thanks for the reply SoundZman.

    Can you explain what you mean by "put one lead on the purple and one on a good ground source"? Were you referring to the multi-meter leads, or something else?

    If another test will help me confirm the problem, I'd like to do it ... I have a habit of buying parts that I don't need : )

  4. #4
    Jr. Mechanic SoundZman's Avatar
    Join Date
    Apr 2009
    Location
    Santa Clarita, CA
    Posts
    106

    Default

    Well you said your getting 12volt at the red wire but only 1v at the purple, so I assumed you were using a volt meter or multi-meter to measure voltage at the wires, was I correct?

    So you want to take your volt/multi-meter, put it to DC Voltage, put 1 (red) lead on the purple wire (assuming this is the +12v powering the motor) and reference the other lead (black) to a chassis ground. By doing this you're checking to see if the supply voltage to the motor is OK, if you get battery voltage (+12Vdc) by doing this then you know some part of the motor circuit is malfunctioning but if you still get only 1V then you know it's relay.

    Another good troubleshooting tip is to take something that is a known working part and swap it with your suspect part. In other words, swap the relay with another one.

    Hopefully this helps explain thing a little better. Good luck.
    >>>2003 Suburban K1500 LT<<<

    Currently:
    ~Rear overhead DVD
    ~Orion 600D
    ~ 12" Acoustic Elegance AV12
    ~Hankook ATM DynPro A/T's
    ~Flowmaster exhaust

  5. #5

    Default

    Yes, I was using a multi-meter. I understand now what you are saying. I'll give that a shot.

    Thanks a lot!

Similar Threads

  1. Fan blower relay for a 94 GMC Suburban
    By ColonialRovers in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 07-06-2010, 03:54 AM
  2. Heater blower
    By Badbrad10 in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 12-15-2009, 11:45 AM
  3. 02 Trailblazer A/C heater blower fan no work
    By doug rooney in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 1
    Last Post: 10-21-2008, 08:18 AM
  4. heater fan relay
    By soatway in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 10-05-2008, 06:59 PM
  5. Heater/Ac blower problem
    By Zoner in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last Post: 03-22-2007, 06:40 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •