GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default Treble comin out of woofer, aftermarket deck and amp

    I've got a new Alpine deck and its puttin treble and bass out to the amp and in turn to the subwoofer. he deck has subwoofer setting controls and the output jacks on back of deck says subwoofer. so i don't know whats going on. played with all the settings on amp and didn't fix problem. I've heard sometimes that you have to hook certain wires to other wires but don't know details.
    2005 Silverado 1500 LT
    4WD Extra Dark Gray Ext. Cab

    Order of Mods:
    - 20% Tint all around
    - Alpine deck nav,iPod
    - Volant cold air intake
    - Bullydog Power Pup programmer
    - Clifford remote start/security
    - 9 inch Cognitto lift kit
    - Fabtech shocks, chromed out
    - Under carriage coated and painted black
    - 315/70R17 BFGs (34.4x12.4) (winter setup)
    - Brushed aluminum 17" rims
    - 37x13.50R20 Nitto Mud Grapplers (brand spankin new for spring)
    - KMC XD Series Spys black 20" rims

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    Make sure the settings for the RCA outs on the deck are actually set to amp within the internal menu of the apline deck, I know I have a cheaper alpine deck and it only has one set of rca outs but it is adjustable to strictly subwoofer
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    turned auxilery on and theres still treble through the woofer, its also the lowest end alpine deck i can hook my ipod to

  4. #4
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    You probably have the same as I do, You can go internally in the deck and switch the RCA outs from front to subwoofer, if its still f'd up then return it

  5. #5

    Default

    actually take the deck apart? or is there a switch im missing??

  6. #6
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,386

    Default

    Its within the menu settings of the deck you should be able to switch it to a mono for the subwoofer to take the treble out, most likely form the factory the menu settings are to send the signal for a front speaker setup. If you cant figure it out let me know, I will take a peek at mine and see what I can come up with tomorrow, send me a private message if you need some more help

  7. #7

    Default

    Does you deck have a hi-pass filter? If it does, tune it to 120 and it will only push that to your component speakers or w/e you have in the doors.

    You should be able to adjust the frequencies in the subwoofer controls as well. If you can, set it to 100 and it will only allow bass to the sub.
    2005 Chevy Silverado Z71 in Black

    6" BDS Suspension Lift | 3" BDS Body Lift |17" Rock Crawler Stellies | 35" Cooper STTs | 4.56 Yukon Gears | AirAid CAI and TBS | Flowmaster 40s | HyperPAC Programmer


    2001 TJ Sahara in Sienna

    3.5" RE Suspension Lift | 33x12.50 Baja MTZs | D30/44 | ROKMEN Merc Front Bumper | Warn Rockcrawler Rear w/ Carrier | Warn M8000 Winch



  8. #8
    Master Mechanic Burden33's Avatar
    Join Date
    Mar 2009
    Location
    Goose bay, Labrador Canada
    Posts
    982

    Default

    what kind of amp are you useing to push it try running a mono amp if your not and that should stop the problem


    Fabtech/Banks Ram Air |Fuel Off Road/ 315/70/17 duratracs |Hyper tech / Spencershids |
    Color Matched Bowtie |15% Tint on Front Windows|20% Tint on Back Windows




    Chevy Ridin' High
    "Black rims are as cool as a boner at a swim meet"

  9. #9

    Default

    check to make sure your high pass filter switch on your amp is on.

  10. #10
    Jr. Mechanic TUTONE's Avatar
    Join Date
    Apr 2009
    Location
    Southern Ohio
    Posts
    84

    Default

    Could buy an aftermarket crossover to fine tune which frequencies go to which speakers.

    1990 Chevy Suburban V1500 4x4 "Church Bus"
    5.7L TBI
    3" lift - 35" tires
    WARN Manual Locking Hubs

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. wiring harness for aftermarket deck..?
    By Block8head in forum Audio, Video & Gadget Tech
    Replies: 8
    Last: 06-13-2010, 04:09 PM
  2. aftermarket deck with bose speakers
    By ferg's04 in forum Audio, Video & Gadget Tech
    Replies: 0
    Last: 02-27-2010, 02:52 PM
  3. Aftermarket Woofer install.....
    By Oscarvan in forum Audio, Video & Gadget Tech
    Replies: 9
    Last: 09-11-2009, 07:23 PM
  4. new deck what did u do with cassette deck
    By zubbiez in forum Audio, Video & Gadget Tech
    Replies: 16
    Last: 05-18-2009, 11:19 AM
  5. 02' Silverado, aftermarket deck won't hold presets
    By danegerous in forum Audio, Video & Gadget Tech
    Replies: 7
    Last: 04-12-2009, 03:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •