GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Thread: Motor dead :(

  1. #1
    Jr. Apprentice
    Join Date
    May 2009
    Location
    Vancouver BC Canada
    Posts
    22

    Default Motor dead :(

    So last month my oil pump went on me and i know have zero compression in one cylinder and a tick int he top end She does almost have 300,000kms on her so its time for a change or rebuild. Now locally i can get EVERY part for the rebuild for $1600CAN. thats every part internally brand new. Then plus machine work and the time for me to put it back together.

    Now locally there is a great machine shop that has a rebuilt 2000 5.7L motor. $2135CAN Plus my motor. Sounds like a chance for some more power. BUT what would i have to change to make it work? harness? ECU? Transmission gonna be good to hold the new power? I have Edelbrock headers for my 5.3, will they bolt up to the 5.7?

    ALSO i just got a call back from a friend who has a 6.0L Gas for cheaper, low k's. What would that mean?

    Thank in advance for all of your time and information

    Matt Demick

  2. #2
    Jr. Apprentice
    Join Date
    May 2009
    Location
    Vancouver BC Canada
    Posts
    22

    Default

    So i've looked around and it seems that i can use all of my stock sensors harness and trans with the 5.7. 6.0L i would want to upgrade the transmission. there are a few right ups of ppl swapping in a 6L inplace of there old 4.8's.

    This is very encouraging. But would love some input from you guys. thanx

    http://www.****************/forums/i...howtopic=38043 one site with info

  3. #3
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    First off what are you driving, and anything from a 4.8, 5.3 or 6.0 will not work on the 5.7. The 4.8, 5.3, and 6.0 are a whole different line of motors from the 5.7. The motor swap however may work but from what I have read you need the computer from the 6.0 to replace the 5.7's.
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  4. #4
    Jr. Apprentice
    Join Date
    May 2009
    Location
    Vancouver BC Canada
    Posts
    22

    Default

    Sorry about that. I have a 5.3L in there right now. Sorry i got messed up there. i was tole the 6L would work because it uses the same tune as the 5.3

    and i re read everything and your right the 5.7L is very different. wich sucks cuz thats the only guy who gotten back to me
    Last edited by Demick; 05-05-2009 at 01:07 AM.
    2000 Silverado Z71 4x4 fully loaded. 6L Swap, Fully built 4l60E Transmission w/ custom shift kit, intake, Edelbrock headers, custom 3" exhaust, MSD wires, 3" lift, 33" tires, Hypertec Programmer.

  5. #5

    Cool Motor dead

    Check out GMs new crate 5.3 H.O.engine. It has 327hp and 347 lbs torque. A true bolt-in. Down here its not much more than a good rebuild and it has a 24 month/50,000 mile warranty. Its part # is 19165628.

  6. #6
    Jr. Apprentice
    Join Date
    May 2009
    Location
    Vancouver BC Canada
    Posts
    22

    Default

    I found a 6.0L here at a locla shop i trust. it has 97,000kms on it and they only want $1000CAN for it. think thats what i'll go for. But hey i'll even call the dealer about that new 5.3

  7. #7
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    I am not sure about the 6.0 into a 5.3, just not sure about the tranny differences

  8. #8
    Jr. Apprentice
    Join Date
    May 2009
    Location
    Vancouver BC Canada
    Posts
    22

    Default

    Well swaped in the 6L last weekend! works awesome, bolted right in. changed nothing

Similar Threads

  1. Dead Pedal?
    By ChevyFan in forum POLLing place
    Replies: 16
    Last: 06-22-2010, 02:54 PM
  2. Perhaps a dead horse?
    By gnel in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 05-18-2009, 09:29 AM
  3. Dead Battery
    By starultra in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last: 02-22-2009, 06:23 PM
  4. Dead A/C
    By ct9a in forum General Chevy & GM Tech Questions
    Replies: 12
    Last: 08-06-2008, 10:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •