GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 11 of 11
  1. #11

    Default My experience with a similar problem

    One forum suggested a bad cap and rotor. Changed that. It was about time anyhow.
    No Joy.

    Splashed a bit of gas in the carb. It fired right up. So its a fuel problem... BUT its so intermittant, it leads me to believe its electrical. When it does catch, it starts on the first few revolutions, as opposed to continuous cranking with no joy.

    MY truck is a 1994 carberated 350.

    Where is the fuel pump relay?

    K think i found the relay to the left of the engine on the firewall... right under the plastic cover that says fuel pump relay...

    It started, I shut it off restarted it 3 times or more then it quit and I am back to square one.
    Last edited by OAbrey; 09-24-2009 at 01:33 PM.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Truck cranks but no start
    By smokey308 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 11-16-2010, 09:54 PM
  2. Help K1500 Suburban cranks fast slow fast doesnt start
    By boyscout in forum GM Powertrain
    Replies: 1
    Last: 01-23-2010, 08:01 PM
  3. cranks but won't start
    By duece209 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 5
    Last: 01-07-2010, 06:24 PM
  4. 2000 Savanah Van cranks but won't start
    By SuperMatt in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 07-14-2009, 09:46 PM
  5. Car was hard to start then didn't start at all
    By bmxr123 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 1
    Last: 07-03-2009, 08:48 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •