GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 12
  1. #1

    Default 03 "Service 4 wheel drive" message

    Another new guy, thats me. I own a 2003 Chevy Silverado, that I have owned from day one. Love the truck and never had ANY major issues. Driving to work this morning my "Service 4 wheel drive" message came on. Have not used 4 Wheel drive in over 3 months (haven't had the time). The truck is driving fine and is not making any noise. The light came on for about 5 minutes and then shut off. When I got to work I shut the truck off and then turned it back on and the message did not come back on. I have 130,000 miles on the truck. But as mentioned have never had any problems with it. The truck is never really taken off road, but I do try and use the 4 wheel drive every once in a while to keep fluids fresh. Whoops Guess I should ask the question, does anyone have any suggestions on this?
    Last edited by 03z71ls; 05-27-2009 at 12:04 PM.

  2. #2

    Default

    Quote Originally Posted by 03z71ls View Post
    Another new guy, thats me. I own a 2003 Chevy Silverado, that I have owned from day one. Love the truck and never had ANY major issues. Driving to work this morning my "Service 4 wheel drive" message came on. Have not used 4 Wheel drive in over 3 months (haven't had the time). The truck is driving fine and is not making any noise. The light came on for about 5 minutes and then shut off. When I got to work I shut the truck off and then turned it back on and the message did not come back on. I have 130,000 miles on the truck. But as mentioned have never had any problems with it. The truck is never really taken off road, but I do try and use the 4 wheel drive every once in a while to keep fluids fresh. Whoops Guess I should ask the question, does anyone have any suggestions on this?
    I just looked in the Manual and it said that went the service 4WD message came on, its telling you there may be a Problem with the Automatic Transfer Case.Beyond That I would have someone take a look at it.If the light comes back on.
    Last edited by 99'HEARTBEAT; 05-27-2009 at 04:26 PM.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    Drive it for a few more days. If it continues to come on, then you may have a problem. Since you cycled the ignition, and it didn't reset a code, then maybe it was a fluke.

    My DIC has said that maybe twice in 4 years. Never have had a problem though
    2005 Chevy Silverado Z71 in Black

    6" BDS Suspension Lift | 3" BDS Body Lift |17" Rock Crawler Stellies | 35" Cooper STTs | 4.56 Yukon Gears | AirAid CAI and TBS | Flowmaster 40s | HyperPAC Programmer


    2001 TJ Sahara in Sienna

    3.5" RE Suspension Lift | 33x12.50 Baja MTZs | D30/44 | ROKMEN Merc Front Bumper | Warn Rockcrawler Rear w/ Carrier | Warn M8000 Winch



  4. #4

    Default

    welcome to the site

  5. #5

    Default "Service 4 wheel drive" message

    Thanks for the replies, it has not come back on, so I am thinking might just have been a fluke. Appreciate the suggestions. Will post pics soon, nothing really that special about my '03. But it's my Chevy and I love having it.

  6. #6

    Default

    Quote Originally Posted by 03z71ls View Post
    Thanks for the replies, it has not come back on, so I am thinking might just have been a fluke. Appreciate the suggestions. Will post pics soon, nothing really that special about my '03. But it's my Chevy and I love having it.
    Thats good to hear that the light has not come back on,Looking forward to seeing pics of your Ride.

  7. #7
    Legend bry2500's Avatar
    Join Date
    Oct 2008
    Location
    Gloucester, MA
    Posts
    2,201
    Blog Entries
    4

    Default

    Welcome to the site!!!!!
    BRYAN

    "IF YOU DON'T TREAT IT LIKE A TRUCK IT'S JUST A REALLY BIG CAR"

    02' Avalanche 2500 Onyx Black
    8.1L Vortec
    43,000 miles

  8. #8

    Default

    welcome to the site

    2003 Z71 Silverado LS
    Access roll up cover
    Bed Rails
    Billet Grill insert
    Bed Rug
    CB with PA system
    Waiting to be installed
    Two 8in RF HX2 punch( would have 12s but they got stolen)

  9. #9
    Master Mechanic
    Join Date
    Apr 2009
    Location
    Owens Cross Roads, Alabama
    Posts
    634

    Default

    ive got a 04 and it does that from time to time.i was told the fluid in the differential was low.so i went to a local place to have them change my oil and check everything out and sure enough the fluids were low.i still havent taken it to the dealer to have them service it yet though
    -Dylan
    2004 Silverado 4x4
    4.8L
    1986 K5 Blazer
    8" Superlift w/39.5 super swampers
    1992 GMC Jimmy "Blue Bomber"
    4.3L Vortec

  10. #10

    Default Service 4wd

    the SERVICE 4WD has come on my wife's 05 suburban. we rarely use the 4wd on it. it has no sound or fluid loss from the transfer case. i found somewhere, pull the 'TRAC' fuse for 15 seconds while the truck is running. that cleared the message for about 6 months now.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. 1999 Silverado - "Security" message stays on
    By Gotechslack in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 05-21-2014, 03:29 PM
  2. 03 Quadra Steer "Service 4 Wheel Steer"
    By meash20 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last: 11-19-2012, 08:50 PM
  3. "Service Four Wheel Drive"
    By Artie3boys in forum GM Powertrain
    Replies: 1
    Last: 12-29-2008, 05:17 AM
  4. Replies: 0
    Last: 11-13-2007, 08:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •