GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default starting problem

    I got a 99 jimmy that turns over and but wont run. took it all apart and it is getting fuel. Any ideas ???

  2. #2

    Default

    I would check for spark first. If you have spark it should try to fire or backfire providing you have fuel. What did you take apart?
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    it has spark. its a friends truck and he had the intake off and the fuel hoses and he said it was pouring gas out when he started it. the engine light is also on i am now informed so maybe he can fix it from that i hope.

  4. #4

    Default

    Hi,
    What Engine is in this vehicle?

  5. #5
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default

    check out this post i put up with my problem. sounds a little similar to what i am experiencing
    http://www.gmtruckclub.com/forum/showthread.php?t=23206
    2000 silverado with a 5.3l v8, shorty headers, upgraded plugs, 10 mil wires, magnaflow high flow cats, flowmaster 80 series muffler(2 in 2 out) w/ 18 inch stainless silverline tips. i have a k&n CIA. its a 4x4 z71 offroad package. Ls model.
    extended cab 160k miles, truxedo low profile bed cover, diablo sport predator tuner.
    reman tranny @ 130k miles
    Chris

  6. #6
    Master Mechanic
    Join Date
    Apr 2009
    Location
    Owens Cross Roads, Alabama
    Posts
    634

    Default

    ive got a 92 jimmy with a 4.3L vortec and had that problem a few years ago.it was my fuel injectors.they were pumping fuel.just way too much and flooded the engine out everytime i went to start it.did you smell gas really strong before it started doing this while you were driving?
    -Dylan
    2004 Silverado 4x4
    4.8L
    1986 K5 Blazer
    8" Superlift w/39.5 super swampers
    1992 GMC Jimmy "Blue Bomber"
    4.3L Vortec

Similar Threads

  1. starting problem
    By ymh401 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 12-10-2009, 04:19 PM
  2. Starting problem with my 4.8l
    By muffler_bearing in forum GM Powertrain
    Replies: 4
    Last: 08-13-2008, 03:30 PM
  3. Starting Problem
    By spayne67 in forum GM Powertrain
    Replies: 3
    Last: 01-08-2008, 05:50 AM
  4. Starting problem??? [Expired Topic]
    By BigWhite2500 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 11-11-2006, 10:39 AM
  5. Starting problem [Expired Topic]
    By BigWhite2500 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 09-19-2006, 07:55 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •