GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default Electronic Fuel pump doesn’t work [Expired Topic]

    Electronic Fuel pump doesn’t work

    Hi everybody,


    I did something stupid, I left my fuel pump run dry  And now it doesn’t make any sound, I checked the fuses but they are good.
    I put 12V on connector G still nothing.

    I’m running out of ideas, I think the fuel pump is broken.
    What do you think, can I try anything else? because the fuel pump is located in the fuel tank
    :shock:

    Chevy Parts

    Regards,
    Peter.
    Peter Smet
    Haasdonk, Belgium

  2. #2

    Default

    No if you have tried putting 12v to the pump at the back where the wires come off the frame chances are the pump is gone. Drop the tank and remove the pump and replace.
    A test light at the frame rail where the wires leave the frame and go to the fuel pump should light when the key is on, if not its in the wireing, fuses.

    Technology is great, when it Works,
    And one Big Pain in the Ass When it Doesn’t.
    Detroit Iron Rules, All the Rest are Just Toys.
    94 GMC Burban, 5.7L (350), 4X4, Auto
    86 GMC Burban, 350, 2 WD, Auto
    79 GMC pickup plow truck, 400, Full time 4X4, Auto
    86 Pontiac Fiero SE, 2.8L, Auto, only mid engine American car
    See a Pattern yet?

    15 year GM assembly line worker.

  3. #3
    Guest

    Default

    Wow, that's too bad. It's very likely that your pump has had it. On the plus side, look how long it lasted you. At least you can still get around under propane power! :D

  4. #4

    Default

    Modern pumps don't like to go dry at all. Could be very bad. :-(

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  5. #5
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default

    I replaced the fuel pump, and the Suburban starts good.
    But when I drive the rpm doesn’t go above 2000 rpm I think the fuel filter is dirty what do you think?
    :roll:
    Peter Smet
    Haasdonk, Belgium

  6. #6

    Default

    That's possible, it's never a bad idea to change out. What yeah suburban do you have, engine, etc?

    Suburban Parts

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  7. #7
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default

    Hi Steve,

    My Suburban is a 1500 from 93 it has a 350 TBI Engine
    with 160500 miles on it.
    Peter Smet
    Haasdonk, Belgium

  8. #8

    Default

    Where do you get the parts? How did you end up getting a Suburban over there anyhow? Are there dealerships?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  9. #9
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default

    I get most of my chevy parts on the internet; we also have a local shop here SpeedShop they also have a shop in LA and they order the parts in the USA.

    The only real Chevrolet you can buy here are the Corvette and the trailblazer.
    You can’t buy a new Suburan in Belgium. :(

    My suburban was originally from Texas, it came to Belgium as a used car.
    Peter Smet
    Haasdonk, Belgium

  10. #10

    Default

    Really. What part of Texas? Mind you, texas is bigger than France, so it could have come from anywhere. Just wonder if it came from near me.

    BTW, that's a t-shirt that I've seen around here. "Texas is bigger than france"...


    http://www.texasterritories.com/deta...duct_id=K01x01

    Just something funny.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

Page 1 of 2 12 LastLast

Similar Threads

  1. New electronic fuel pump making noise and running constantly [Expired Topic]
    By Davandy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last Post: 04-21-2011, 11:21 PM
  2. It’s Not a Chevy, It’s Not a Ford… (lots of big pictures)
    By Crawdaddy in forum The Coffee Shop ~ Chit Chat
    Replies: 15
    Last Post: 01-31-2011, 04:17 PM
  3. 05 Avalanche - radio lights don't work at night [Expired Topic]
    By lakebear99 in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 0
    Last Post: 03-05-2009, 08:11 AM
  4. '07 Avalanche [Expired Topic]
    By jibarra16 in forum Chevy Avalanche Forum (Escalade EXT)
    Replies: 2
    Last Post: 01-04-2007, 07:32 AM
  5. Welcome [Expired Topic]
    By Steve in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 06-16-2005, 11:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •