GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default projection tv problems

    i was given an RCA projection television by my cousin. it worked fine when he had it, it worked fine for a few weeks after i got it. then one day it blinked off and back on, hmmm... thought nothing of it until it did it again a few min later but this time it turned off and wouldnt turn on until about 10 min later. we dealt with the problem for several weeks until my mom bought a new tv and gave us her RCA Scenium projection tv. i know for a fact that it worked wonderfully for them for several years. well it worked great for us untl yesterday when it shut itself off.

    i did notice with the old tv, that my fiance could be watching it for hours at a time, but no sooner than me sitting down in front of it, it would start acting up, not just once, but everytime i came into the room. i think it is me. i have some kind of magnetic field about me that my projection tv's hate. hooked up to the tv, i have as a control center is a yamaha surround sound vis component cables (the blue, green, and red ones). hooked into that is a dvd player, a ps2, and the sound for my satelite. hooked into the s-video on the tv is my satelite.

    i have seemed to notice that i can play my ps2 with no adverse problems, but when i am watching the satelite or a dvd, they both start acting up. i am getting desperate here. i have checked the voltage, the hetrz, and they all both in operating range. i am getting preturbed with this situation. can anyone please help me out
    2000 silverado with a 5.3l v8, shorty headers, upgraded plugs, 10 mil wires, magnaflow high flow cats, flowmaster 80 series muffler(2 in 2 out) w/ 18 inch stainless silverline tips. i have a k&n CIA. its a 4x4 z71 offroad package. Ls model.
    extended cab 160k miles, truxedo low profile bed cover, diablo sport predator tuner.
    reman tranny @ 130k miles
    Chris

  2. #2
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default

    any ideas on anything folks?

  3. #3
    Legend
    TRPLXL2's Avatar
    Join Date
    Jan 2009
    Location
    Norwalk, Ohio
    Posts
    3,368
    Blog Entries
    8

    Default

    I never had the problem with the shutting off part, but when I bought my new T.V. I had issues with the picture. I ended up ditching the standard AV/input jacks, and I replaced all of them with the gold plated cables. And with surround sound you really should be running gold plated cables, it gives you way better sound quality. The only thing I can say is the actual projection module might be bad, and if that's the case then you would be better buying a new one and getting away from projection style.

    Does the picture have dead spots on the side when it's running, if it does than the projector itself is going bad. Hope you figure it out.
    2004 Chevy Colorado
    LS1 5.7 swap/TBSS rear axle swap

  4. #4
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default

    the funny thing is, that the first one i had works fine at the guy whos house its at now. it has to be something in my duplex. my sound quality is excellent. i have everything ran by THX theater cables, there are no dead spots in the picture, i should get new bulbs, but i am afraid of opening up the tv due to capacitors within it. i guess i will have to find an appliance guy or something

  5. #5
    Legend bry2500's Avatar
    Join Date
    Oct 2008
    Location
    Gloucester, MA
    Posts
    2,201
    Blog Entries
    4

    Default

    I had a 52" RCA Scenium and it did the same thing. I called many service shops but no one would touch the thing. Circuit city refunded me my money and I upgraded to a Sony LCD projection. One of the service guys told me that this was a common issue and the simplest fix was to replace the tv. After labor just to diagnose the problem I could afford a new one anyways.

    Sorry for the bad news.


    Does yours have the built in DVD player? This is one of the reasons no one wanted to service it. 4 different shops told me this.
    BRYAN

    "IF YOU DON'T TREAT IT LIKE A TRUCK IT'S JUST A REALLY BIG CAR"

    02' Avalanche 2500 Onyx Black
    8.1L Vortec
    43,000 miles

  6. #6
    Legend cascott325's Avatar
    Join Date
    Aug 2008
    Location
    Lawrenceburg, Kentucky
    Posts
    1,709

    Default

    well, i solved the problem. i would make y'all guess what it is, but that would take too long, so here it is. i had to put a piece of wood under the front of the tv
    http://www.gmtruckclub.com/forum/alb...pictureid=5478

Similar Threads

  1. S10 ZR2 4x4 problems
    By footballmn in forum GM Powertrain
    Replies: 3
    Last: 01-21-2010, 08:35 AM
  2. 4wd problems
    By NewfZ71 in forum GM Powertrain
    Replies: 3
    Last: 01-11-2010, 10:35 AM
  3. 4wd problems.
    By 95Chevyk1500 in forum GM Powertrain
    Replies: 2
    Last: 12-10-2009, 01:05 PM
  4. Chevy Silverado Heater problems blower problems
    By bidutch in forum GM Powertrain
    Replies: 3
    Last: 12-13-2007, 05:59 PM
  5. Got a few problems
    By 95chevyguy in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last: 04-16-2007, 12:03 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •