GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default break lights not working

    my break lights are not working but all my bulbs r good and also all my other lights are coming on. I relocated my groung. trurnig signals,backup light, and night time running light is coming on thoe. I tried everything would there be a fuse just for the break light. If any one out there can help me that would be good thanks

  2. #2

    Default

    What year is your Ride??,that would really help in giving you some Advice.

    MIKE


    99"SILVERADO
    5.3 l 3.73 l G80
    BLACK BEAR CUSTOM TUNE
    SNUGTOP l COLORMATCH l KATZKIN










  3. #3

    Default

    And did you say the rear turn signals are working? Are they the same bulb as the brake lights, or separate?
    When you hear hoofbeats, look for horses not zebras.

  4. #4
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    could be (depending on which vehicle you drive) that the circuit board that the tail lights are plugged into might be having an issue, could be a loose ground , or more often than not i have seen this issue with someone having incorrectly hooked up a trailer light kit in the truck also in which case you can simply unhook the trailer light wires and it should start working again.

    hope this helps some but without knowing what kind of truck you have or what year model it's kind of hard to be more specific.

  5. #5

    Default break lights not working

    my bad i got a 78 chevy k-10

  6. #6

    Default break lights not working

    And yes my turning signals are working too.

Similar Threads

  1. Tail lights not working
    By carlsauction in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 05-28-2010, 08:39 PM
  2. dash lights not working
    By mxkjk2 in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 01-19-2009, 09:27 AM
  3. No break lights, no gauge cluster backlights AND no chimes for headlights
    By oOcornflakeOo in forum Audio, Video & Gadget Tech
    Replies: 25
    Last: 01-03-2009, 01:15 PM
  4. Clearance Lights not working
    By Bluerado31 in forum Chevy C/K Truck Forum
    Replies: 1
    Last: 08-01-2008, 02:01 PM
  5. No Break lIghts for my 2004 1500 Silverdao
    By freemanjc in forum GM Powertrain
    Replies: 2
    Last: 09-26-2007, 09:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •