GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default antilock brake help

    hey new to this forum. I'm trying to get my father-in-laws van figured out. He has a 1993 chevy g 20 van, that when i give it throttle, the antilock brake light comes on and the van looses all power as if the antilock brakes are engaging. i pulled the rear drums off and found that the linings are down to metal. i have new chevy parts on order but was wondering if this could cause the brakes to engage. any thoughts and response would be a great help.

  2. #2
    Jr. Engineer Jacqson's Avatar
    Join Date
    Jan 2009
    Location
    North Vancouver, BC
    Posts
    221

    Default

    Quote Originally Posted by merril j View Post
    hey new to this forum. I'm trying to get my father-in-laws van figured out. He has a 1993 chevy g 20 van, that when i give it throttle, the antilock brake light comes on and the van looses all power as if the antilock brakes are engaging. i pulled the rear drums off and found that the linings are down to metal. i have new parts on order but was wondering if this could cause the brakes to engage. any thoughts and response would be a great help.
    Welcome aboard. I would check and see if you're getting any error codes because I can't see worn rear brakes causing that to happen but the warning may come on alerting that there is a problem in the braking system. You may also have a defective anti lock brake module, but as far as the truck losing power, I can't help you there.
    2011 Chevy Silverado 3500HD, Dmax/Allison, Taupe Gray Metallic, Line-x over the Rail & Rockers, S&B Intake, Banks Monster Exhaust, Rigid Dually D2's, Cognito Leveling Kit, Cognito Steering Braces plus much more.

    "Suburban" There is no Substitute.:great:

    SOLD - My Loaded up 02 2500 Suburban.

  3. #3
    Legend kgibson181's Avatar
    Join Date
    Jul 2009
    Location
    Cedar Grove, NC
    Posts
    1,309
    Blog Entries
    2

    Default

    this was a problem on my 96 blazer my abs light came on when driving but I didnt lose power like in your case. Mine turned out to just be a computer issue, took it to my local mechanic, he hooked it up and punched in a few codes and I was on my way with no issues.

    2003 Silverado 1500
    V8 4.8L 294ci
    2 inch Pro Comp Leveling Kit
    3 inch Rough Country Lift
    33 inch Nitto Terra Grapplers
    5% Tint All Around
    2 12" Kenwoods

Similar Threads

  1. antilock brake problem????
    By michiganhunter in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 2
    Last Post: 06-26-2010, 02:13 AM
  2. antilock sensors adjustment
    By russetway in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 03-29-2010, 02:36 PM
  3. Do all 93 1/2 tons have rear antilock
    By regal557 in forum Lifted & Offroad Suspension
    Replies: 1
    Last Post: 07-25-2009, 09:39 AM
  4. Third Brake LED Help
    By Swatchvy in forum Chevy Truck Accessories
    Replies: 7
    Last Post: 07-12-2009, 03:29 PM
  5. what wire for brake controller. says none power on brake. [Expired Topic]
    By viken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 08-24-2005, 06:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •