GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default help...no speedo/odometer

    I am having a problem that is driving me nuts. I have a 91 Chevy k1500, 350, 700r4. Neither the Speedo, odometer, nor cruise controls are working. I changed out the inst. cluster and the vss. It does not have a mechanical speed sensor, electric magnetic. I originally thought it was the cluster so I changed that, no good. A few weeks later the service engine light came on, checked for codes and got 24. I than changed the vss. Still nothing. I checked the harness to the vss with a multi meter while the key was in the on position and got a reading from it. Any suggestions or ideas are appreciated.

    thanks,
    Brandon

  2. #2

    Default

    Quote Originally Posted by braspu View Post
    I am having a problem that is driving me nuts. I have a 91 Chevy k1500, 350, 700r4. Neither the Speedo, odometer, nor cruise controls are working. I changed out the inst. cluster and the vss. It does not have a mechanical speed sensor, electric magnetic. I originally thought it was the cluster so I changed that, no good. A few weeks later the service engine light came on, checked for codes and got 24. I than changed the vss. Still nothing. I checked the harness to the vss with a multi meter while the key was in the on position and got a reading from it. Any suggestions or ideas are appreciated.

    thanks,
    Brandon
    You probably have a bad DRAC module. The DRAC is located behind the glove box. This is what converts the analog signal to a digital signal.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    what were the codes? and did you fix them?

  4. #4

    Default

    Sooo. Im having the same problem right now. What is this DRAC module? I have no idea what im lookin for
    "We must be the change we wish to see"
    -Ghandi


    -New Project
    1989 GMC C1500 Sierra ST
    5.7L 350 V8
    5 Spd Manual Trans.

  5. #5

    Default

    Quote Originally Posted by m.gauthier View Post
    Sooo. Im having the same problem right now. What is this DRAC module? I have no idea what im lookin for
    The early trucks had a DRAC Module which is the speedometer buffer. Later, the DRAC was incorporated into the PCM. What year is your truck? Have you thought about including your truck info into your signature?

  6. #6

    Default

    Its an 89 gmc C1500
    350 V8 5.7L

  7. #7

    Default

    Quote Originally Posted by m.gauthier View Post
    Its an 89 gmc C1500
    350 V8 5.7L
    I believe 1992 was the first year GM used a DRAC in the trucks. The 89 still used a speedo cable and the vss sensor was located in the speedo head. The 2 wires from the vss went directly to the PCM. To change the ratio on an 89 a reduction box was used on the speedometer cable at the trans or transfer case.

  8. #8

    Default

    Quote Originally Posted by Jimmiee View Post
    I believe 1992 was the first year GM used a DRAC in the trucks. The 89 still used a speedo cable and the vss sensor was located in the speedo head. The 2 wires from the vss went directly to the PCM. To change the ratio on an 89 a reduction box was used on the speedometer cable at the trans or transfer case.

    VSS is located in the transmission. I changed it ,but im still not getting any signal to my speedometer/odometer gauge. And my cruise isnt working. So its gotta be some wiring somewhere is faulty. Just dont know where. Multimeter check? Where at? whats the reading supposed to be in which locations?

    Also. Where is the VSS buffer? Apparently the speedo wired run into a buffer according to the haynes manual. Know where its at?

  9. #9

    Default

    So you are saying you have a VSS sensor on the trans and no speedo cable?

  10. #10

    Default

    yah its electrical. I changed the VSS thinking that was it. But that didnt work. Im still getting the 24 code

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. odometer questions
    By bdchevy in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last: 03-18-2010, 07:43 PM
  2. odometer problem
    By Tiny1987 in forum GM Electrical Tech
    Replies: 7
    Last: 12-30-2009, 04:59 PM
  3. way to fix trip odometer ?
    By RATRODKING in forum General Chevy & GM Tech Questions
    Replies: 4
    Last: 11-10-2009, 03:22 AM
  4. help...no speedo/odometer
    By braspu in forum General Chevy & GM Tech Questions
    Replies: 11
    Last: 08-18-2009, 02:49 PM
  5. Odometer Electrical
    By jostic in forum Audio, Video & Gadget Tech
    Replies: 1
    Last: 09-27-2008, 11:18 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •