GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default Defrost not working

    My 1997 Chevy Silverado all of a sudden will not go to defrost. When you flip the switch to defrost, it goes to the floor vents and nothing comes from the defroster vents. Is there a stuck lever somewhere? where would I find it?
    Any help is appreciated.

  2. #2

    Default

    BUMP.
    Anybody??
    1997 Chevy Silverado 1500 210K miles:
    350 Vortec/4L60E, 3.42 posi, Underdrive crank pulley, K&N filter, Superchips power programmer, mallory coil, true dual exhaust, torque swirl TB spacer, and more!


    1991 Pontiac Trans Am GTA- L98 Superram
    1992 Subaru SVX LS-L- Way too many mods to list!

  3. #3

    Default

    i had this exact same problem with my 93 chev truck. i had it fixed almost 10 years ago at the dealership. he didn't even charge me! the service advisor reached under the dash and reconnected a lever that got disconnected. I could see it go up and down when i changed air flow from defrost to floor etc. sorry not much help, but hopefully yours is a simple fix

  4. #4

    Default

    Quote Originally Posted by jetjarv View Post
    i had this exact same problem with my 93 chev truck. i had it fixed almost 10 years ago at the dealership. he didn't even charge me! the service advisor reached under the dash and reconnected a lever that got disconnected. I could see it go up and down when i changed air flow from defrost to floor etc. sorry not much help, but hopefully yours is a simple fix
    Thanks for the reply. I checked it out and didn't see anything obviously disconnected, But I'll get under there and flip the switch around and try to see what is working what exactly.

  5. #5
    Jr. Apprentice Haner's Avatar
    Join Date
    Aug 2009
    Location
    Southern California
    Posts
    12

    Default

    Quote Originally Posted by budfreak View Post
    Thanks for the reply. I checked it out and didn't see anything obviously disconnected, But I'll get under there and flip the switch around and try to see what is working what exactly.
    I have the same issue. All the levers seem to be connected. It seems like the stroke of the levers is not long enough, however. I wish we could draw here and my explanation would be more clear. Did you ever find the problem and fix it?

  6. #6

    Default

    there is a box under the dash you have to hit it to losen it up its located by the floor vents

  7. #7
    Jr. Apprentice Haner's Avatar
    Join Date
    Aug 2009
    Location
    Southern California
    Posts
    12

    Default

    Quote Originally Posted by jt_5.7 View Post
    there is a box under the dash you have to hit it to losen it up its located by the floor vents
    So, we're thinking something is jammed up inside the box and a good slap will free it up?

Similar Threads

  1. defrost problems..help?
    By Silverado1500 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 12-17-2009, 03:57 PM
  2. Defrost CFM
    By Six point in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 10-20-2009, 10:19 PM
  3. Can you add rear defrost?
    By Tdaz250 in forum Audio, Video & Gadget Tech
    Replies: 19
    Last: 09-29-2009, 02:42 PM
  4. 03 silverado goes to defrost
    By danduf98 in forum Audio, Video & Gadget Tech
    Replies: 0
    Last: 08-07-2008, 12:52 PM
  5. Help no heat only defrost
    By challutz in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 0
    Last: 02-12-2007, 04:36 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •