GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default '93 with a 4L60E? no TV valve,

    My '93 Silverado won't downshift on the highway when I floor it (ever since I bought it 2 weeks ago). It kinda revs up a little bit, like it's about to downshift, but then it goes righ back into 4th gear. I went to adjust my TV cable, and found that it was not present.

    I quote my Hayne's Manual:

    Beginning in 1991, an electronically controlled automatic transmission, the Hydramatic 4L80-E was installed on some vehicles......bla,bla, mentions nothing about 4L60-E untill.......The 4L60-E and the 4L80-E electronic controlled transmissions are not equipped with a Throttle Valve (TV) cable assembly. The transmission functions normally controlled by the TV cable are controlled electronically...

    Now, I quote Jimmiee from this page: http://www.gmtruckclub.com/forum/showthread.php?t=22539

    Quote Originally Posted by Jimmiee View Post
    You have a 4L60 or 700R4 as it's commonly called. Your truck has a TV Cable to control line pressure. To verify this look at the throttle body. You will see 2 cables. One goes to the gas pedal and if you follow the other it runs down to the transmission.

    There's a big misconception here on this forum about 700s and 4L60Es. GM started calling the 700 a 4L60 in 1990. 4L60 means 4 speed, longitudinal, with a torque rating of 60. This is still a 700R4 however because it is not electronically controlled.
    In 1994 the 4L60 became the 4L60E. No more TV cable!
    So, either:
    1. I have a 4L60-E installed from the factory in '93 that needs a new sensor or something electrical
    2. I have a 4L60-E (or some random transmission) that somebody threw into the truck last month so that they could get rid of it and didn't bother to put a TV cable on it.
    3. Something even stranger (most likely)
    (truth is, I have no idea)

    here are the numbers stamped on the sides:

    driver's side:
    43 0923 0403
    -and-
    8685060

    Passenger's side:
    5
    -and-
    m30

    Please help me figure out what transmission I have, what's wrong with it, and whether I am supposed to have a TV cable. Thanks!

  2. #2

    Default

    The 4L60 <700> has a cable and the <E> does not. Take a look under the truck at the transmission. If it has a cable you will see it on the passenger side bolted to the transmission. If you have a 4L60E you will have a round connector with a wire harness in that location. Here's a picture of the 4L60E showing the electrical connector:


    Now either your cable is missing <4L60> or if you have a 4L60E you have an electrical problem. Many things can cause no kickdown. The first thing to do is make sure your throttle body is getting full throttle when the gas pedal is floored. If it is then the next step is to check for codes. A TPS Sensor, Mass Air Flow Sensor, Dirty Air Cleaner, VSS Sensor can all cause no Kick Down.
    Attached Thumbnails Attached Thumbnails 99-4l60e.jpg  
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    Quote Originally Posted by Jimmiee View Post
    The 4L60 <700> has a cable and the <E> does not. Take a look under the truck at the transmission. If it has a cable you will see it on the passenger side bolted to the transmission. If you have a 4L60E you will have a round connector with a wire harness in that location. Here's a picture of the 4L60E showing the electrical connector:


    Now either your cable is missing <4L60> or if you have a 4L60E you have an electrical problem. Many things can cause no kickdown. The first thing to do is make sure your throttle body is getting full throttle when the gas pedal is floored. If it is then the next step is to check for codes. A TPS Sensor, Mass Air Flow Sensor, Dirty Air Cleaner, VSS Sensor can all cause no Kick Down.
    Thanks very much for the picture! I was able to find the plug right away, so now that I know that I have a 4L60-E, I can find out why it's not working. I am going to go have the codes read, but before I do, let me tell you about another thing that I think might be related. When I get out on the highway, after about 10 minutes of driving, the Check Engine light comes on and stays on until I come to a stop at a red light. It will stay off as long as I'm piddling around town, but as soon as I get back on the highway for a few minutes, it comes right back on. 1.)Will the code reader tell me the reason for the light if the light is not actually on at the time when I plug in the reader? 2.) of the things mentioned, (TPS Sensor, Mass Air Flow Sensor, Dirty Air Cleaner, VSS Sensor) would any of them cause what I have described?

  4. #4

    Default

    Quote Originally Posted by strantor View Post
    Thanks very much for the picture! I was able to find the plug right away, so now that I know that I have a 4L60-E, I can find out why it's not working. I am going to go have the codes read, but before I do, let me tell you about another thing that I think might be related. When I get out on the highway, after about 10 minutes of driving, the Check Engine light comes on and stays on until I come to a stop at a red light. It will stay off as long as I'm piddling around town, but as soon as I get back on the highway for a few minutes, it comes right back on. 1.)Will the code reader tell me the reason for the light if the light is not actually on at the time when I plug in the reader? 2.) of the things mentioned, (TPS Sensor, Mass Air Flow Sensor, Dirty Air Cleaner, VSS Sensor) would any of them cause what I have described?
    Since the check engine light came on the reason for no kick down is your transmission is in a failsafe mode. Each code has it's own failsafe parameters. Just a guess but the most common 4L60E code is the P1870 which is a Torque Converter slip code. Go get it scanned. Have you thought about buying a code reader? There's a thread here this morning where I posted a link to a good code reader.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  5. #5

    Default

    the m30 code is a 4l60e i looked it up on my 93 heavy half ton but my transmission was rebuilt not even a year ago and it is acting like it does the same prob but no engine light comes on but when i floor it it feels like it has no power to make it up the hills it feels like when your pulling a heavy trailer with a half ton in drive you floor it, it barely moves
    Last edited by OleBlue93; 08-27-2010 at 03:23 AM.
    BRIAN AVERITT

Similar Threads

  1. 4L60E Valve Body 94 up
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 12-03-2009, 05:10 PM
  2. 4l60E VALVE BODY W SOLENOIDS 93-94 REBUILT & TESTED
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 11-14-2009, 10:40 AM
  3. off the shelf valve body 4L60E
    By 9191gmc in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last Post: 06-08-2009, 04:06 PM
  4. tci boost valve for 4l60e 4l65e
    By Twiztidss in forum General Classifieds
    Replies: 0
    Last Post: 04-14-2009, 08:21 PM
  5. tci boost valve for 4l60e
    By Twiztidss in forum General Classifieds
    Replies: 7
    Last Post: 04-02-2009, 10:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •