GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 3 123 Last Post byLast Post by
Results 1 to 10 of 28
  1. #1

    Default Climate control problems after battery change

    I am sure some (or all) have heard of this problem, but I need some help because its driving me nuts! I installed a new battery in my wifes 2002 Chevy Tahoe. Immediately afterward, the controls would only blow heat through the defrost setting, no matter what the dial was set to. Also, when I tried the AC the light on the button would just blink and never turn the AC on. Its a real pain in the butt that this happened just from a battery swap!!!

  2. #2

    Default

    I've never heard of that problem. Did you clean the battery cables with a battery terminal tool? Did you hook up the battery with the key in the on position?

    Try disconnecting the battery for 5 minutes and see what happens.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3
    Legend bry2500's Avatar
    Join Date
    Oct 2008
    Location
    Gloucester, MA
    Posts
    2,201
    Blog Entries
    4

    Default

    Can't say this happened to me but something similar with the wife's Toyota Sienna. I changed the battery and then my auto window down/up didn't work. It would work manually but not automatically. After 3 days it started working again. Don't know why but I figure it had to go through somekind of reset cycle.

    I know that Toyota and GM are two completely different animals but alot of electronics function similarly. This may be your issue.

    How long has it been since you replaced the battery?
    BRYAN

    "IF YOU DON'T TREAT IT LIKE A TRUCK IT'S JUST A REALLY BIG CAR"

    02' Avalanche 2500 Onyx Black
    8.1L Vortec
    43,000 miles

  4. #4

    Default

    Had this happen to me yesterday with a radio swap. It blew only hot air on the passenger side. While at the dealer having the radio programmed I mentioned the problem to them and they said often an off/on with the key will reset things. It worked with me. Mine's working fine now.

  5. #5

    Default

    It has been quite awhile now. We have just lived with it until we could find an answer. I will try to disconnect for 5 minutes and then reconnect and see if that works.

  6. #6

    Default

    Quote Originally Posted by F E Knucklebuster View Post
    Had this happen to me yesterday with a radio swap. It blew only hot air on the passenger side. While at the dealer having the radio programmed I mentioned the problem to them and they said often an off/on with the key will reset things. It worked with me. Mine's working fine now.

    do you mean an off/on with the key while swapping the battery? I disconnected the battery for ~5 minutes and tried again, no luck. anybody else have any ideas? this is crazy that all this could happen from a battery swap! I still can't believe it!!!

  7. #7

    Default

    Here was my understanding.

    When the battery is disconnected the actuators controlling the climate control can lose their position. They think they are in the cold position when they are really in the hot. Disconnecting the battery again won't correct it - it's an on/off thing with the key. You may have to experiment - ie - off/on without cranking, off/on without cranking 3 times, off/on with cranking. Mine did it with a simple off/on with cranking.

  8. Thanks Shubes thanked for this post
  9. #8

    Default

    Quote Originally Posted by F E Knucklebuster View Post
    Here was my understanding.

    When the battery is disconnected the actuators controlling the climate control can lose their position. They think they are in the cold position when they are really in the hot. Disconnecting the battery again won't correct it - it's an on/off thing with the key. You may have to experiment - ie - off/on without cranking, off/on without cranking 3 times, off/on with cranking. Mine did it with a simple off/on with cranking.

    Sorry for the idiocy, but when you say "on/off with cranking" do you mean just normal starting of the vehicle? does the dial on the heater need to be set to hot when doing this? I have been driving with this problem since winter, so normal starting hasn't changed anything. I will try your other two suggestions though.

  10. #9

    Default

    Right - but with a delay at each step.

    I'm just learning how all of this new computer controlled stuff works - most of it beyond me. I sounds like the actuator that controls the hot/cold on that side is either stuck or shot. I don't think I'm being much help here especially when I venture out into the opinion venue.

    That being said, I found a couple of things online for you to try. Make sure you let us know if one works.

    1
    I might have a solution for some of you that had the climate control fail to defrost mode only, after I replaced the battery. I tried several things that I read about on different forums and while I was playing under my dash I bumped my Power Seat switch. To reset the seat position, I pushed my Driver preference button and my Climate Control defaulted to my old setting and is now working.


    2
    Pulled the hvac/ecas fuse and left it out for 1 minute. reinstalled the fuse and started the vehicle with the ac off. Turned the ac on and it made some motor noises (im sure it was the motors resetting on the actuators) within 30 sec cold air from both sides
    Last edited by F E Knucklebuster; 06-25-2009 at 12:42 PM.

  11. #10

    Cool climate control problems after battery change

    Ive experianced my a/c blowing hot air after battery disconnect. Turned key off and on a few times and this cleared things up.

Page 1 of 3 123 Last Post byLast Post by

Similar Threads

  1. For all having ac problems after a battery change this may help
    By littlerichard in forum GM Electrical Tech
    Replies: 2
    Last: 04-07-2014, 04:41 PM
  2. 05' climate control
    By TroyT in forum General Chevy & GM Tech Questions
    Replies: 2
    Last: 04-20-2010, 10:56 AM
  3. 2003 Silverado with climate control problems
    By nhenson1 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 04-06-2009, 05:06 PM
  4. Climate Control
    By punkdu in forum Chevy Trailblazer Forum (GMC Envoy)
    Replies: 2
    Last: 01-25-2009, 12:22 AM
  5. need climate control help
    By bart6180 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 3
    Last: 12-07-2008, 11:56 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •