GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1

    Default keep losing voltage

    my 03 silverado keeps dying and i put in a new battery and tested the alternator. not sure what else to look for, my battery gauge keeps going up and down and the truck idles weird. it gets really bad with the a/c on. not sure if this is a common problem but could really use some help.

  2. #2
    Master Mechanic
    Join Date
    Apr 2009
    Location
    Owens Cross Roads, Alabama
    Posts
    634

    Default

    if its a new battery id try a new alternator anyway..sombody else might be able to help you a little better though
    -Dylan
    2004 Silverado 4x4
    4.8L
    1986 K5 Blazer
    8" Superlift w/39.5 super swampers
    1992 GMC Jimmy "Blue Bomber"
    4.3L Vortec

  3. #3

    Default

    I would start by making sure your connections are clean. Battery, alternator, the big grounds. If that doesn't fix it, sounds like a bad alternator to me. Is it better when the truck is cold? Then get worse as the engine warms up?
    When you hear hoofbeats, look for horses not zebras.

  4. #4
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    ^^ What he said x2 ^^
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  5. #5

    Default

    i guess u could say that it's worse when it warms up. if i have the a/c off i can drive for a few minutes before it cuts off. it starts right back up and will go a little farther then cut off again. when i just crank it up and turn on the a/c it just idles up and down and almost cuts off. i thought it might be the alternator cuz sometimes when they test ok they can still be bad.

  6. #6

    Default

    Your alternator won't cause your truck to die unless the battery is dead. Does the problem happen after the battery is charged?
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  7. #7

    Default

    it died with a new battery. i just tried an alternator and it still idled wierd. does anybody else have a suggestion?

  8. #8

    Default

    Ground connections is where I would start.
    2008 GMC Sierra 2500HD Ex. Cab, Fire Red, 6.6L Duramax LMM Equipped with UTG Rocker Pods


    AMSOIL is the only oil company that...,"Recommends 25,000 mile oil changes","Gives up to four times better wear protection","Warranties your engine against oil related failure"

    Preferred Customers Save up to 30% Click here!!!
    Executive Direct Jobber ZO# 1695636
    Scott Douglass 248-721-1002
    Order online:
    www.1st-synthetics.com




  9. #9

    Default

    X2 on ground connections. Has anyone worked on the truck before this problem happened? If so that's where I would be looking. Engine repair, alarm, stereo, accessories? Any of these repairs done lately? If so that's where you will find your problem.
    You never mentioned if you checked for codes. On today's vehicles this is the very first step on ANY kind of an electrical or mechanical problem.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  10. #10

    Default

    no codes. i'm about to go back out and work on it. i've never had it worked on. this is the first problem i've ever had. i'll keep u guys updated.

Page 1 of 2 12 LastLast

Similar Threads

  1. losing power
    By pryormancan in forum Member Introductions
    Replies: 9
    Last Post: 07-05-2010, 03:03 PM
  2. Losing power
    By aggie99 in forum GM Powertrain
    Replies: 0
    Last Post: 09-24-2009, 01:02 PM
  3. 98 K-1500 losing antifreeze
    By CharlieP in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 05-24-2009, 10:00 PM
  4. key doesn't work i'm losing my mind
    By bassalive in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 11-26-2008, 07:05 PM
  5. Ford's losing $$$$
    By ChevyLover in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 04-28-2006, 09:01 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •