GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default 4wd Actuator not engaging

    As it says, the actuator on the front axle of my 90 k1500 is not engaging when I pull the lever to 4wd. I can see the front driveshaft turning, so the transfer case is good. I know its an electrical problem. The light in the cab for 4wd will come on every once in a while, but will turn off again in a few seconds of driving in 4wd. What are the common spots to see problems with this system's electrical?

  2. #2

    Default

    The actuator is pretty easy to pull from the axle. Take it out and have someone shift in and out of 4wd. Make sure it's working properly before you start pulling apart wiring harnesses.
    When you hear hoofbeats, look for horses not zebras.

Similar Threads

  1. 4WD not engaging
    By generalduke01 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 30
    Last: 07-02-2014, 06:31 PM
  2. 4wd not engaging
    By split2303 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last: 12-26-2013, 10:25 AM
  3. A/C Clutch not engaging
    By promod in forum General Chevy & GM Tech Questions
    Replies: 19
    Last: 07-09-2012, 07:14 AM
  4. 95 Suburban 4WD not engaging
    By 95burban in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 13
    Last: 01-06-2010, 02:10 PM
  5. Engaging The 4WD On 94 Suburban
    By Trophy in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 12-06-2009, 05:17 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •