GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default The odometer is acting strange [Expired Topic]

    When I drive on the highway and I use my turn signals the odometer jumps up and down. :roll:
    Does anyone have an idea what the problem is.

    Thanks,
    Peter Smet
    Haasdonk, Belgium

  2. #2

    Default

    ??? I've never heard anything like this happening before. What do you mean it jumps up and down? The numbers go higher and lower, or the contrast/brightness goes up and down?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  3. #3

    Default

    Everything is electronic in the cluster, Fieros have a lot of problems with bad grounds and do a lot of things like this.

    Try putting an extra ground from the battery to the engine and one from the engine to the firewall.

    Electrical problems SUCK!. :evil:

    Dam I can't spell.

    Didn't you just change motors or something?

    If you missed a ground or didn't get a good ground this could be the problem. :D

    Technology is great, when it Works,
    And one Big Pain in the Ass When it Doesn’t.
    Detroit Iron Rules, All the Rest are Just Toys.
    94 GMC Burban, 5.7L (350), 4X4, Auto
    86 GMC Burban, 350, 2 WD, Auto
    79 GMC pickup plow truck, 400, Full time 4X4, Auto
    86 Pontiac Fiero SE, 2.8L, Auto, only mid engine American car
    See a Pattern yet?

    15 year GM assembly line worker.

  4. #4
    Moderator
    Davandy's Avatar
    Join Date
    Jun 2005
    Location
    Haasdonk Belgium
    Posts
    1,550

    Default

    Ok I will check every connection maybe I mist one.

    Thanks
    Peter Smet
    Haasdonk, Belgium

Similar Threads

  1. Sierra transmission acting strange
    By GAPartsMN in forum GM Powertrain
    Replies: 6
    Last Post: 02-27-2010, 11:48 AM
  2. My engine [Expired Topic]
    By ProTouringSub in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last Post: 02-25-2006, 11:37 PM
  3. Thermostat??? [Expired Topic]
    By rt1092 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 02-25-2006, 05:48 PM
  4. New How-To forum [Expired Topic]
    By Steve in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last Post: 12-26-2005, 05:34 PM
  5. Welcome [Expired Topic]
    By Steve in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 06-16-2005, 11:57 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •