GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 16
  1. #1
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default 95 burb.... considers napping randomly at stop lights [Expired Topic]

    My 95 has just recently started to sputter and rough idle when I get to intersections, I haven't noticed any problems when the gas is applied. It hasn't died completely yet but randomly as I slow/stop at an intersection it starts to sputter out and sounds like it could actually stop. As soon as it gets some gas its fine again. I changed out the plugs, wires, cap, rotor last week with no change. It seems to be getting a little worse every couple days. Happens about 3 times a day while driving around town. Any thoughts? I dumped some injector cleaner in this morning thinking they might be a little clogged up......

  2. #2

    Default

    Kinda sounds like a vacuum leak or an IAC valve that is not responding the way it should. Those throttle bodies were known for having a vacuum leak under the throttle body, the gasket between the TB and the intake gets real brittle with old age and creates a vacuum leak that is real hard to find.

  3. #3

    Default

    Is this only when at idle? It drives normally at driving speeds as far as you know?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  4. #4

    Default

    That's exactly what my dad's 94 was doing. It turned out to be the a/c compressor trying to take a dump. Turn off your a/c and see if it smoothes out. If so, that would be the problem.
    Gary

    99 K 1500 Suburban
    78 Silverado Big 10 w/factory 454
    00 S-10 Blazer
    1976 Trans Am
    1980 Honda CB900 Custom

  5. #5
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default

    This does only happen at stops, on the road when gas is applied it runs fine. The AC is off now that is a whole additional issue, I need to replace the whole front end of the AC. Its at a shop now getting checked out, I was out of ideas and time. I will let you know how it turns out.

  6. #6
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default

    Just got a call back from the shop, they said that at the intersections the timing is getting set back to about 2 degrees where it would normally be at 17 degrees. The shop manual says the only thing that impacts the timing lke that is the ignition module and they put a new one in and nothing changed so they took it out.

    Picking up the truck in an hour, they give up

  7. #7

    Default

    I thought the computer controlled timing, not the ignition module. Is the check engine light coming on?

  8. #8
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default

    There are no check engine lights and the computer has no maintenance codes either active or in the recent history.

  9. #9
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default

    Problem fixed sort of...... I bought a newer truck

    http://hjalmervik.com/slides/trucks/...YG129624_1.jpg

  10. #10
    Jr. Engineer
    Join Date
    May 2005
    Location
    Minnesota
    Posts
    282

    Default

    Sorry forgot the image tags

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. TPI on a 95 burb ?? [Expired Topic]
    By 2loud in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 09-03-2006, 05:01 PM
  2. how to take dome lights off ? [Expired Topic]
    By sofiah16 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last: 07-20-2006, 12:45 PM
  3. Trailer lights [Expired Topic]
    By samoraml in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last: 06-28-2006, 09:23 PM
  4. Lost dash lights and tail lights???? [Expired Topic]
    By martone68 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 03-12-2006, 07:02 AM
  5. 1998 Chevy Burb Windshield Wiper motor [Expired Topic]
    By QTee in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last: 10-09-2005, 08:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •