GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default jimmy starting issue

    just picked up a 99 jimmy 4.3 vortec. u turn the key it turns on and cut right out. if u spraystuff down the throttle body it stays running until u stop. the fuel pump does come on and the gauge reads fuel.any ideas????

  2. #2

    Default

    Quote Originally Posted by ChevyPrincess View Post
    just picked up a 99 jimmy 4.3 vortec. u turn the key it turns on and cut right out. if u spraystuff down the throttle body it stays running until u stop. the fuel pump does come on and the gauge reads fuel.any ideas????
    You need to check your fuel pressure. The filter may be plugged up since it runs by adding fuel.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3

    Default

    Have your codes checked and see if any trouble codes pop up. If nothing pops up, I'd do as jim suggested and check your fuel pressure.
    1997 Chevy Silverado 1500 210K miles:
    350 Vortec/4L60E, 3.42 posi, Underdrive crank pulley, K&N filter, Superchips power programmer, mallory coil, true dual exhaust, torque swirl TB spacer, and more!


    1991 Pontiac Trans Am GTA- L98 Superram
    1992 Subaru SVX LS-L- Way too many mods to list!

  4. #4

    Default

    If you are spraying starting fluid into the throttle body and this gets it to respond and it does not otherwise, then this is a fuel system problem.

    Complete fuel system service and testing...
    http://www.asashop.org/autoinc/june98/techtotech.htm
    92 GMC Sierra 2500

  5. #5

    Default

    ok so the fuel pressure is 25... max.. that seems really low anyone know what its supposed to be??

  6. #6
    Legend Mean_Green_95's Avatar
    Join Date
    Apr 2009
    Location
    Baton Rouge, Louisiana, United States
    Posts
    1,170

    Default

    Its supposed to be around 60 I believe. Change the fuel filter, then regulator, then pump, or what in a least expensive to most expensive pattern.
    2010 Equinox LT
    2.4, 6 speed auto, power lift gate, remote start, bluetooth, xm.

    1995 Cheyenne C1500 ext. cab(my baby, my first truck)
    5.0, 5 speed, Silverado appearance package, power nothing, bucket seats and console Silverado, painted black interior, eBay halo headlights, eBay chrome tails, eBay cai, dual Flowmaster 40's w/no cats, 15x7 American Racing Hopsters, Walmart fog lights, SS mirrors

Similar Threads

  1. Help starting issue!
    By FireRed in forum Performance & Fuel
    Replies: 2
    Last Post: 04-06-2009, 10:22 AM
  2. 1990 Suburban starting issue...
    By bigjunk93yj in forum GM Powertrain
    Replies: 2
    Last Post: 01-21-2009, 03:01 AM
  3. Cold starting issue!
    By FireRed in forum Performance & Fuel
    Replies: 9
    Last Post: 12-25-2008, 11:29 AM
  4. Starting issue
    By ferco in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 11-13-2008, 08:29 PM
  5. Starting issue Please help
    By trivers in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 2
    Last Post: 10-27-2007, 03:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •