GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11

    Default

    Yep, sorry it went to a new thread, it was a loose bolt on my torque converter to flexplate
    http://www.gmtruckclub.com/forum/sho...t=26120&page=3

  2. #12

    Default

    I know I'm a little late, but I had a problem like that once. Only when I tried to get moving, I had this hurrendous, obnoxiously loud rattling. Turns out, out of the 3 bolts on the flywheel to the torque converter, once was sheared complately off and another was really loose. And to think we took it on a 1600 mile round trip to vegas and back like this... Anyway, glad to hear it's fixed!
    Current truck: 1996 Ford 250, 7.3 Powerstroke diesel. Dana 60 SAS, stage 1 160cc injectors, T500 High Pressure Oil Pump, TS 6-position chip, full 4" exhaust, intake, 285 Falken Rocky Mountain AT's, boost/EGT/trans temp pillar gauges, etc...



Page 2 of 2 FirstFirst 12

Similar Threads

  1. Strange noise after starting the engine
    By rwmoorh in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 07-08-2010, 12:05 PM
  2. HELP - Strange Noise
    By CJM in forum General Chevy & GM Tech Questions
    Replies: 2
    Last Post: 04-25-2010, 06:59 AM
  3. strange noise
    By deckboat234 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 03-04-2010, 03:32 PM
  4. Strange noise under the hood
    By jediracer in forum GM Powertrain
    Replies: 6
    Last Post: 07-08-2009, 10:17 PM
  5. Very strange tapping noise
    By zachh1020 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 02-14-2009, 10:49 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •