GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 4.56 gear installed now......

    2005 Tahoe 10 bolt rear end. installed 4.56 gears..now "service brake system" warning is on. i used hand held power programmer to change Ratio setting and update tire size. Tires where installed prior to gears being installed and "service brake sytem" never came on.

  2. #2

    Default

    Same issue right before I deployed. I've done some research on it, and from what I've read the issue is the VSS and the WSS reporting different speeds therefore setting a code in the EBCM...hence the brake warning lights. I had the same thing...I programmed my tires in and had no issues, but once I programmed the gear ratio, it set the code. When you program it with a handheld, it is only programming the ECM/PCM and not the EBCM.

    The work around that I've been told is to return the settings back to OEM and then use an inline calibrator to calibrate the Speedo as a gauge itself.
    2005 Chevy Silverado Z71 in Black

    6" BDS Suspension Lift | 3" BDS Body Lift |17" Rock Crawler Stellies | 35" Cooper STTs | 4.56 Yukon Gears | AirAid CAI and TBS | Flowmaster 40s | HyperPAC Programmer


    2001 TJ Sahara in Sienna

    3.5" RE Suspension Lift | 33x12.50 Baja MTZs | D30/44 | ROKMEN Merc Front Bumper | Warn Rockcrawler Rear w/ Carrier | Warn M8000 Winch



  3. #3

    Default

    I'm having my gears changed to 4:56 this coming Monday and am worried about the same issue. Here is an inline calibrator I found made by Hypertech...
    http://www.realtruck.com/product/796...or_730102.html

    Bobby - North Carolina
    2008 4x4 5.3L V8
    6" Suspension Lift and 1.5" Body Lift
    20x9 Ballistic Jesters w/35" Toyo Open Country MT's & 1.5" rear wheel spacers
    4:56 Yukon Gears
    Hypertech Speedometer Calibrator
    Baja style bed mount spare tire carrier
    Flowmaster 40 series dual exhaust
    Recon Smoked LED tails/3rd brake lights/black projectors w/switchback LED's in the corners
    N-Fab Nerf Steps
    K&N CAI
    No Fear Pedals
    Tint, Line-X bedliner, Window visors, Rear wheel well liners
    Painted front grill, bow ties and door badges, de-"lettered" tailgate
    Powder coated front and rear bumpers

Similar Threads

  1. Volant CAI installed!
    By 09Z71BLKBST in forum Performance & Fuel
    Replies: 6
    Last Post: 03-30-2010, 06:13 PM
  2. W4M w/ SCT Handheld Installed!
    By omegafiler in forum Product Reviews
    Replies: 19
    Last Post: 08-26-2009, 04:46 PM
  3. New Wheels Installed
    By 04 crew cab in forum Lifted & Offroad Suspension
    Replies: 10
    Last Post: 04-10-2009, 07:33 PM
  4. I installed a new CAI kit.
    By plumber_rob in forum Photo & Video Gallery
    Replies: 5
    Last Post: 02-07-2009, 01:30 PM
  5. Has anyone installed a 2nd Battery??
    By finalday7 in forum The Coffee Shop ~ Chit Chat
    Replies: 4
    Last Post: 12-18-2007, 08:19 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •