GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Normal cycling and compressor temperature?

    Just retrofitted my 89 sub from r12 to 134. I put 8oz.s of ester into the compressor and hand turned it since it had not been run in about 2 years ( the system still had some pressure until I broke the line). I have added about 30oz.s of 134 and the compressor is cycling on for 3 secs and then off continuously. Its also quite hot to the touch- like 2 Mississippi's. I changed all of the orings and put in a new orifice tube. The old orifice wasn't even that dirty even though it has never been changed.

    The pressure on my gauge draws down to about 40psi when it kicks in. But when I turn the a/c switch off and the compressor stops it shoot up past 90 psi. Ive stopped adding 134 at this point because the compressor is getting too hot and sound has also changed- it sounds rougher with more vibration than it did before.

    Do these compressors (Harrison 928, R4 or R6- not sure) usually run hot? Im not sure why the pressure builds so high when its not cycling either. And, yes Im adding 134 to the low pressure port!

    Taking all suggestions!

  2. #2

    Default

    I think you need to flush out the old oil, install a new accumulator, and I think a new pressure switch in addition to the new high/low pressure fittings for 134a. And then stick on a 134a label.

    Then add new oil and add refrigerant by weight per factory specs and check with a high/low pressure gauge set. And the high/low pressures would be by a table based on outside temperature.

    BUT all the factory specs in the factory service manual would be for R-12!

    So I guess the thing to do is send you to the experts in Arizona where they REALLY know their A/C stuff (because it is so hot there!).

    Here is their site...
    (These guys know EVERYTHING!)
    http://www.autoacforum.com
    92 GMC Sierra 2500

  3. #3

    Default

    yeah ive done most of that. problem is that when the compressor cycles off the pressure shoots way back up into the 90+psi. Its supposed to remain stable in the 40s. Not sure why it is constantly fluctuating??

  4. #4

    Default

    Just a SWAG but did you evacuate the system? Any air in the system can cause problems like that.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  5. #5

    Default

    Quote Originally Posted by will89 View Post
    yeah ive done most of that. problem is that when the compressor cycles off the pressure shoots way back up into the 90+psi. Its supposed to remain stable in the 40s. Not sure why it is constantly fluctuating??
    the pressure is supposed to rise on the suction side when the compressor cycles off, it's equalizing with the high side.

    You also MUST get a 134a sensor to replace the R12 sensor, the two refrigerants operate in completely different parameters, you will also need to change the dryer. After doing all that work you MUST also do pull a vacuum on the system otherwise the cooling will be greatly reduced or the compressor could be destroyed. The charging pressures will depend on ambient temperature so you will need to get the the chart from the internet.

Similar Threads

  1. TCC cycling at 65+ mph
    By mz-man in forum GM Powertrain
    Replies: 0
    Last: 05-17-2010, 06:35 PM
  2. Water temp cycling high and low
    By Kraziken in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 5
    Last: 07-26-2009, 09:50 AM
  3. Coolant cycling
    By PurdueGuy in forum GM Powertrain
    Replies: 3
    Last: 08-27-2007, 06:34 PM
  4. AC compressor not cycling
    By collinsperformance in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 12
    Last: 03-16-2007, 12:43 PM
  5. What is normal for oil pressure? [Expired Topic]
    By technojunkie in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last: 11-16-2006, 05:37 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •