GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default Quick RMS question for Sony 5.25"

    I'm looking at some Sony 5.25" 4-way speakers (not the Xplode versions (I know Sony's aren't the best, but I've had really good experiences with their speakers)). According to the Wal-Mart website, they're rated at 35 watts RMS. My amp does 55w x 4 @ 4 ohms, and my head unit has an output of 50w x 4. If I were to get these speakers, would they be ok being hooked to my head unit? Or better yet my amp? And does anyone know the difference between the regular Sony 4-ways and the Xplode 4-ways? I've got a set of older 6x9 4-way Xplodes that have been through hell and still sound fine.
    Last edited by bigburb; 07-31-2009 at 08:12 PM.
    Current truck: 1996 Ford 250, 7.3 Powerstroke diesel. Dana 60 SAS, stage 1 160cc injectors, T500 High Pressure Oil Pump, TS 6-position chip, full 4" exhaust, intake, 285 Falken Rocky Mountain AT's, boost/EGT/trans temp pillar gauges, etc...



  2. #2

    Default

    The amp would be better. The headunit "50 X 4" is a MAX Rating, not RMS, So that means the Headunit is probably like 14-20 RMS. Just make sure you don't give them too much power. Set the gains correctly.
    Silverado Single Cab 2008 Subwoofer/Audio Build - http://www.gmtruckclub.com/forum/showthread.php?t=26310

    -12" AQ HDC3
    -Custom Downfiring Box Tuned To ~37 Hz
    -Diablo Audio Technologies HellFire 1000.1 (1000 Watts RMS)
    -Pioneer DEH-P5000UB, 4GB Flash Drive
    All In A 2008 Single Cab :gasp:

  3. #3

    Default

    Quote Originally Posted by tech2332 View Post
    The amp would be better. The headunit "50 X 4" is a MAX Rating, not RMS, So that means the Headunit is probably like 14-20 RMS. Just make sure you don't give them too much power. Set the gains correctly.
    Alright well that answered one of my questions (thanks again tech2332). Now setting the gain... that's another thing I don't really know how to do CORRECTLY. I'm still pretty new to all of this stereo tuning type stuff.
    Last edited by bigburb; 07-31-2009 at 09:53 PM.
    Current truck: 1996 Ford 250, 7.3 Powerstroke diesel. Dana 60 SAS, stage 1 160cc injectors, T500 High Pressure Oil Pump, TS 6-position chip, full 4" exhaust, intake, 285 Falken Rocky Mountain AT's, boost/EGT/trans temp pillar gauges, etc...



Similar Threads

  1. Quick Question
    By Bowen26 in forum Lifted & Offroad Suspension
    Replies: 1
    Last Post: 01-25-2010, 08:55 PM
  2. Quick 4.3 question
    By RichStom in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last Post: 10-29-2009, 08:15 PM
  3. quick question...
    By Z28Johnny in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last Post: 08-30-2009, 08:32 AM
  4. stereo question - 04 Silverado with aftermarket Sony
    By 1slols1 in forum Audio, Video & Gadget Tech
    Replies: 5
    Last Post: 06-10-2009, 07:08 PM
  5. Quick Question
    By MXZ1983 in forum Lifted & Offroad Suspension
    Replies: 2
    Last Post: 05-13-2009, 08:48 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •