GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default 97' GMC Safari A/C problems.

    I need some help with this one. My mom has a 1997 GMC Safari and the A/C messed up. It has 4 different fan speeds and only 2 speeds work. When you try to switch the fan speed the A/C just shuts off. Any ideas?
    Bagged 06 Silverado Crew Cab.

  2. #2

    Default

    If you have a "blower motor resistor", check that. And check the electrical connector at the fan and/or blower motor resistor.
    92 GMC Sierra 2500

  3. #3

    Default

    I have 97 K1500, your problems sound similar. the control panel/module; the one with the AC on/off, recirc, and blower speed knob are very prone to failure. you can lose just the AC on/off function, the blower speed can can vary up and down, or you can lose the defrost function all at once or just one sympton at a time. there is no way to fix that controller once it starts to go. They cost approx 200. let me know what other symptons you are having.

  4. #4
    Master Mechanic daddytech's Avatar
    Join Date
    Mar 2008
    Location
    Portland TN
    Posts
    672

    Default

    Quote Originally Posted by div4scpro View Post
    I have 97 K1500, your problems sound similar. the control panel/module; the one with the AC on/off, recirc, and blower speed knob are very prone to failure. you can lose just the AC on/off function, the blower speed can can vary up and down, or you can lose the defrost function all at once or just one sympton at a time. there is no way to fix that controller once it starts to go. They cost approx 200. let me know what other symptons you are having.
    My wife's suburban was doing the very same thing and it was the switches on hers too. I put a brand new blower motor in hers because the bearing in the old one had come out and it was squealing very loudly. put the new motor in it and it runs fine now but only on low and High , the middle speeds are all seemingly not working then the switch replacement and eureka works on all speeds once again.

  5. #5

    Default hey daddy tech

    Quote Originally Posted by daddytech View Post
    My wife's suburban was doing the very same thing and it was the switches on hers too. I put a brand new blower motor in hers because the bearing in the old one had come out and it was squealing very loudly. put the new motor in it and it runs fine now but only on low and High , the middle speeds are all seemingly not working then the switch replacement and eureka works on all speeds once again.
    How are you man. Having a similar problem with a 96 tahoe. All the functions on the ac heater control work, ie defrost, floor vent etc, however, I have lost all speeds of airflow except for the maximum or highest setting. I was just wondering, where you might have found the control switch replacement? Did you order a new one or? I think my problem is in the high low switch only. Who knows.

Similar Threads

  1. Replies: 0
    Last Post: 06-16-2009, 05:20 PM
  2. Tan/Black Ignition wire - 95 safari
    By bimmer84 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 01-28-2009, 03:04 PM
  3. i don't see anything really based for Safari and Astro vans
    By eaglegcil in forum The Coffee Shop ~ Chit Chat
    Replies: 2
    Last Post: 10-18-2007, 05:38 AM
  4. Safari Basket/ Spare holder?
    By Skarch in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 11
    Last Post: 09-09-2007, 01:17 PM
  5. GMC Safari Van
    By Cableguy in forum Chevy Uplander & GM Minivan Forum
    Replies: 4
    Last Post: 06-20-2007, 08:15 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •