GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Angry Alternator/Guage cluster problems '03 1500

    Hey guys! first post! got into the forums here in the last year rebuilding my monte carlo and Ive got the bug and cant stay off of em!

    Heres my prob:

    i bought an 03 silverado ext cab ls with the 4.8L v8 about 11 months ago. i have had the guage cluster replaced twice, the original one; the tripometer wouldnt log my miles. 2nd one just got fried and stopped working but the part where the odometer was would stay lit up in but would just show the square grids. it would do this with the truck off too. my third one is holding up so far....

    if i remember correctly the alternator went out about the same time my 2nd cluster went out. when i took it in they also said i had a manifold gasket leak?!? truck had about 60k on it at the time. never got a check engine light or anything but the dealership said it was throwing codes when i took it in. they said the alternator was working intermittently, thats why the week before that they couldnt find anything wrong when i took it in(everytime i stopped or went in reverse it would like choke out and sometimes die. it took me breaking down in the middle of a busy freeway during rush hour for them to figure it out!)

    that was about 7 months ago that it was all replaced. i got a light about 2k ago saying service airbag. its now at 69k. the other day i got on it WOT and the lights went dim and said battery not charging. I was manual shiffting it at the time too if that helps. but after i slowed down it went away and didnt see it till the other day and it came on constantly along with service brake booster. Autozone tested the alternator said it was bad! lucky theres a waranty on the alternator and i have a warranty on the truck!

    Has anyone had problems like this before? is this a common issue with this year truck/motor? Sorry for the long post, any help would be greatly appreciated!

    -Nick

  2. #2

    Default

    i had a similar problem where the speedometer broke and didnt give me the correct mph... and then the fuel gauge did the same thing just keep spinning and spinning... its not just ur truck a majority of the vehicles made around 2002 through 2005 have this problem...
    my uncles tahoe had the same problem too

Similar Threads

  1. Guage Cluster pin/Harness Question
    By murdog94 in forum GM Electrical Tech
    Replies: 7
    Last: 04-18-2010, 06:59 PM
  2. Changing guage cluster on 2010
    By RICKZ710 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 7
    Last: 04-09-2010, 12:10 PM
  3. Were to get a cluster guage face and needles?
    By SmokeU in forum Chevy Truck Accessories
    Replies: 3
    Last: 09-05-2009, 08:34 AM
  4. 88 Guage Cluster
    By ParisDude in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 0
    Last: 08-07-2009, 05:05 PM
  5. How do I take off my fan controll pannel to access my guage cluster?
    By Falcone in forum Chevy S10 Forum (GMC Sonoma)
    Replies: 4
    Last: 04-28-2009, 09:32 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •