GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default 88 S10 2.5 issues...help!

    88 2.5 problems

    I have an 88 S10 with the 2.5 motor. Has always been hard to start (Takes a lot of cranking to get it to fire up), but a few weeks ago it got to where it is darn near impossible to keep idling. Checked EGR and PCV, both good. When you can get it driving, the engine surges at times. Hooked up a vacuum gauge, and it shows a steady needle. Will be checking codes this morning to see if anything is stored. Am thinking maybe fuel pump???

    Any and all suggestions are greatly appreciated.

  2. #2

    Default

    Could be fuel pump related.
    To determine that you'll need to check fuel pressure at the engine.
    Has the fuel delivery system ever been cleaned?
    The 2.5 was never known as a smooth running engine and real problematic during cold start conditions.
    Once you get it running try some SeaFoam in the vacuum system, it could possibly just be suffuring from carbon build up in the intake and combustion areas.
    If it hasnt been done in a while you might check the spark plug wires and plugs.

  3. #3

    Default

    Thanks Tim. Turns out had a vacuum leak at the intake manifold, so I replaced that and the TB gasket. Then had a strange thing happen...got it running smoothly, and notice the MAP sensor was not connected. Connected it, and it starting acting up again. Disconnected it, and it ran just fine. Thinking bad sensor?

  4. #4

    Default

    Yep, sounds like a bad sensor. Check the wire harness before you replace it. I found part of the harness with bare wires grounding on a sharp edge under the hood on two of our USN S-10's a few years ago and they acted the same way.

Similar Threads

  1. 4x4 issues
    By yankee3 in forum Member Introductions
    Replies: 3
    Last: 06-27-2010, 11:35 PM
  2. 4x4 issues
    By yankee3 in forum General Chevy & GM Tech Questions
    Replies: 0
    Last: 06-27-2010, 07:28 PM
  3. 4x4 Issues.
    By 1995ChevyHoe in forum GM Powertrain
    Replies: 11
    Last: 01-19-2010, 04:30 PM
  4. ac issues
    By brooklyn718 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 2
    Last: 09-25-2008, 03:02 PM
  5. I've got issues.
    By 95CTburb19 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 6
    Last: 04-27-2007, 11:12 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •