GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8
  1. #1

    Default Rear tail lights not working

    I have a 1993 1/2 ton 4x4 with no rear tail ligts. It has a drawtite brake set up and the wires are a mess. I would like to remove the drawtite kit and just wire it back to stock. I have the manual on the truck but the diagram does not help me.Any one have a photo or discription of the wire set up for stock?

    Thanks,
    Tag

  2. #2
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,390

    Default

    Sounds like you have a rats nest to deal with, but I do know that trucks with your style taillights have problems with the circuit boards, just take a look within the socket the bulbs go in, if there is any scorching they are shot, you can pick those boards up at most junkyards for cheap. it may help instead of the headache of rewiring
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  3. #3

    Default

    Yes all the tail lights are new, along with the sockets. When wee pulled the bed off for the paint I unpluged the wrong plug. (Dumb A$$) pulled lots of wires out. I dont need the drawtite so I want to re-wire with the factory harness.

  4. #4

    Default

    Probably best to go to a wrecking yard with the tools to remove the tail lights and take your camera.

    See how this all is wired on another vehicle. Take plenty of pictures.

    Also might want to take a few wet paper towels in a baggie so you can clean the wires off and see the wire colors in your pictures.

    Don't forget in the center under the rear bumper is a connector(s) for the tail lights.
    92 GMC Sierra 2500

  5. #5

    Default

    Bingo.... The area under the bumper is what I need what does the harnes look like. The drawtite was put on in 1993. I think they cut the harness grounded it then put the drawtite on... Any idea what years are the same? We have one you pull it in my area and they have no 93's. Wire color would help....

  6. #6

    Default

    You should be able to fix this with just a few connectors.


    When you say you have no taillights, do you mean just the taillights, or do the turns/stop and reverse not work either? The wiring is quite simple. You should have a four conductor cable coming down the left frame rail to the bumper. Light green is reverse lights, brown is taillights, dark green and yellow are stop/turn. I can never remember which side is which. Doesn't matter. There was, and hopefully still is a plug behind the bumper so you can isolate all the rear lights, including plate lights, from the truck. Use a test light or a meter to confirm all four wires work properly before going any further. If the taillights (brown wire) don't work, you need to fix that first. It may be as simple as a blown fuse. Once you get that working, it's just a matter of tracing backwards (forward LOL) from each light assembly to the plug, and matching the colors up. Remember to tie the plate lights into the brown wire. Its possible there are two more wires coming down from the front of the truck. These would be for electric brakes, and battery charge wire. I don't know if GM had full tow package wiring in 93 or not. If they are factory, the would likely be blue for brakes and orange for charge. If they are there, just cut them off, and tape the ends well.

    Keep us posted
    When you hear hoofbeats, look for horses not zebras.

  7. #7

    Default

    Quote Originally Posted by 2COR517 View Post
    You should be able to fix this with just a few connectors.


    When you say you have no taillights, do you mean just the taillights, or do the turns/stop and reverse not work either? The wiring is quite simple. You should have a four conductor cable coming down the left frame rail to the bumper. Light green is reverse lights, brown is taillights, dark green and yellow are stop/turn. I can never remember which side is which. Doesn't matter. There was, and hopefully still is a plug behind the bumper so you can isolate all the rear lights, including plate lights, from the truck. Use a test light or a meter to confirm all four wires work properly before going any further. If the taillights (brown wire) don't work, you need to fix that first. It may be as simple as a blown fuse. Once you get that working, it's just a matter of tracing backwards (forward LOL) from each light assembly to the plug, and matching the colors up. Remember to tie the plate lights into the brown wire. Its possible there are two more wires coming down from the front of the truck. These would be for electric brakes, and battery charge wire. I don't know if GM had full tow package wiring in 93 or not. If they are factory, the would likely be blue for brakes and orange for charge. If they are there, just cut them off, and tape the ends well.

    Keep us posted
    Thank you the black wire was painted red grounded ot WHALA lights........

    Thank you,
    Tag

  8. #8
    Legend unplugged's Avatar
    Join Date
    Sep 2006
    Location
    High Deserts of SoCal
    Posts
    2,554

    Default

    Glad you were able to fix the problem. Don't know if it would have helped, but the e-trailer.com site has lots of good harness/installation info and some great videos like this one:
    [nomedia="http://www.youtube.com/watch?v=DtGZkOOjC9k&feature=channel_page"]YouTube - Wiring Harness Installation - 2006 GMC Sierra - etrailer.com[/nomedia]


    Last edited by unplugged; 08-22-2009 at 10:37 AM.
    There is no way to happiness....happiness is the way.:yipi:
    http://kx6ijq.blu.livefilestore.com/y1pcOFVNH4ix1hjyGUVyXK5LRfef7qSeWzlZDorpQhIEfkZ2ZA  _vXMYypuKMJFw671uF2ZPhjez_j-atRmcjM2zQKpQi1JSsB75/burb1.JPG
    High Desert SoCal
    93 K1500 burb (personal) 350 AT 3" Lift 250K+
    02 Honda Civic LX
    Looking for a 1990's Miata for an engine swap

Similar Threads

  1. 04 Tahoe Rear tail lights not working
    By bulldawg06 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last: 11-25-2012, 02:03 AM
  2. 82 K10 Tail and Reverse Lights Not Working!
    By ahobson1 in forum Chevy C/K Truck Forum
    Replies: 7
    Last: 06-20-2010, 08:08 PM
  3. Tail lights not working
    By carlsauction in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 7
    Last: 05-28-2010, 08:39 PM
  4. blacked out head lights and tail lights
    By 04blackz71 in forum Chevy Truck Accessories
    Replies: 6
    Last: 10-28-2009, 07:23 PM
  5. Trading My Stock Tail Lights for Euro Tail Lights
    By ippielb in forum Chevy Truck Accessories
    Replies: 5
    Last: 07-10-2009, 11:50 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •