GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 2 of 2
  1. #1

    Default Hydro Boost Assembly required

    Hello

    I have experianced a sudden loss of Braking power,this symptom came and went.Some times the pedle would be very sensative and other times the braking power would be very vauge.Now the braking feels like it has no boost at all.Much like when you have a crimped or leaking vacume hose.

    This is on a 1990 Suburban 6.2 Diesel.I have been told that the Hydro Boost assemply or more to the poiint one sensor is at fault.I would like to know where I can get one from.GM no longer lists the Boost assembly in its catalouges.

    Many thanks

    Mike Hill

  2. #2

    Default

    Try auto parts stores.

    Or wrecking yards.
    92 GMC Sierra 2500

Similar Threads

  1. Advice Required - Intake/Exhaust Upgrade Options
    By drwdominance in forum Performance & Fuel
    Replies: 10
    Last Post: 05-05-2010, 06:38 AM
  2. Boost??
    By rockfoot in forum GM Diesel & DuraMax
    Replies: 1
    Last Post: 04-07-2010, 11:14 AM
  3. hydro boost woes
    By tumleweed in forum General Chevy & GM Tech Questions
    Replies: 0
    Last Post: 04-15-2009, 07:40 PM
  4. Hydro-Boost
    By Hookjr1199 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 4
    Last Post: 07-19-2007, 07:47 PM
  5. Hydro-boost problem?
    By Taggart in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 12
    Last Post: 05-07-2007, 10:43 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •