GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5

Thread: No Heat

  1. #1

    Default No Heat

    When i turn the heater on all im gettin is cold air. where should i start lookin for the problem????

  2. #2

    Default

    If the blower is not working on all speeds, you could look at replacing the Blower Motor Resister.

    If the blower works on all speeds (including MAX), then it is most likely the Heater Core.

    Is there any evidence of fluid or moisture on the passanger side under the glove box, dash, or on the carpet up on the firewall?
    Pavement sucks... :grrrrrr:



    1994 K1500 4x4 Ext. Cab
    PCM chip and Xenon 8000k bulbs
    350cu.in bored over .050"
    balanced Crank, 10:1 compression
    Flat top pistons,cam,ported heads
    Option Racing Cold Air Intake
    Holley Throttle Body Spacer
    Accell Igition, 45kv coil
    FloTech Headers, no CATs, dual exhuast
    Goodyear Silent Armor A/T 305/70-16
    Pioneer SupertunerIII CD USB Bluetooth
    Kicker ZX200.2 ZX Amp
    Kicker Audio COMP 10" Subwoofer

  3. #3

    Default

    Nope. no moisture at all. Ive also heard that the lines going through the fire wall could be air locked or even possibly the coolant is low. have you heard of that? i personally figured it would be the heater core too. but i thought id ask about any other ideas. maybe even the thermostat is shot?

  4. #4
    Master Mechanic zubbiez's Avatar
    Join Date
    Feb 2009
    Location
    Eagle Mountain Utah
    Posts
    663

    Default

    how does your anti freeze look? I once bought a truck that un be know to me had some really dirty looking anti freeze, turned out to be a radiator stop leak some sneeky bastard had put in the truck. long story short that crap had pluged the heater core, I took the heater lines off and blew air threw them until they got unplugged. worked fine after that. oh and if the anti freeze is really dirty Id recommend flushing out the system wheen you blow out the heater core.
    2000 Silverado Z71 Whipple Supercharger, JBA Headers,3" cat back Flowmaster Exhaust, Volant cai, Pioneer Preimer deck,Orion subwoofer,03 signal light mirrors,03 taililghts

  5. #5

    Default

    i would try back flushing the heater core,
    take the heater hoses off at the firewall
    spray compressed air through not to much pressure tho you car rupture the heater core
    take the garden hose with a spray nozzle and fill her back up
    repeat

    2003 Z71 Silverado LS
    Access roll up cover
    Bed Rails
    Billet Grill insert
    Bed Rug
    CB with PA system
    Waiting to be installed
    Two 8in RF HX2 punch( would have 12s but they got stolen)

Similar Threads

  1. Heat!!!
    By theburban in forum Chevy Truck Accessories
    Replies: 18
    Last Post: 11-02-2010, 01:30 PM
  2. No Heat [Expired Topic]
    By chevy_nox in forum Chevy Equinox Forum (GMC Terrain)
    Replies: 3
    Last Post: 05-18-2010, 08:07 AM
  3. No Heat!
    By hskerprid in forum General Chevy & GM Tech Questions
    Replies: 10
    Last Post: 10-13-2009, 06:30 AM
  4. No heat up front, but heat in rear on '83 'burb
    By FUNFINDER in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last Post: 04-20-2009, 02:50 PM
  5. to heat or not to heat
    By tumark in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 1
    Last Post: 04-11-2007, 07:05 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •