GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 7 of 7
  1. #1

    Default Engine runs rough RPM's jump like it want to downshift

    I have a 96 tahoe that has been running rough off and on. Traveling @ 45-55 light on the accelerator with little to no load/strain the engine "bucks" and the RPM's jump a couple hundred then returns back down to where it was. Occasionally the service engine light comes on. Sometimes it doesn't. Been to the dealer 3 times for a diagnostic. Nothing identified.

    Almost acts like it is trying to downshift.

    Any advice?

  2. #2

    Default

    Some of these issues are hard to daignose online, especially when you cannot get a code. My first thought though is a tranny issue. I would suggest you go to a good transmission shop and let them have a look at the prindle switch. As well, a bad torque converter and several other things could cause that. I would hate to see you just start replacing parts at a big cost and still not have the issue resolved, that is why I am suggestiong a tranny shop.

  3. #3

    Default

    Just curious if there is an update for this issue?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  4. #4

    Default

    I had a similar problem in my 02 yukon. Tranny shop put a shift kit in and it fixed the problem. Some to do with the lockup gear not holding because the piston is aluminum and the case is steel. SHift kit installs a steel piston.
    Rob from Dirty Jersey
    02 GMC Yukon SLT
    99 Yamaha Royal Star V-4
    My Motto in life:
    If it doesn't effect the sun coming up in the morning then it's not worth worrying about.

  5. #5

    Default

    How hard does the shift kit kick in when shifting?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  6. #6

    Default

    It does not seem to bad to me. I have driven other tahoe's and yukon's and it feels pretty much the same.
    Rob from Dirty Jersey
    02 GMC Yukon SLT
    99 Yamaha Royal Star V-4
    My Motto in life:
    If it doesn't effect the sun coming up in the morning then it's not worth worrying about.

  7. #7

    Default

    Well, they are smoother than they used to be. My Suburban has a shift kit, and it kicks hard if the RPMs are up high enough. Like getting kicked by a mule.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

Similar Threads

  1. '96 Sub Runs rough, again.
    By MichaelJT in forum GM Powertrain
    Replies: 9
    Last Post: 08-30-2010, 01:37 PM
  2. rough downshift from 2-1
    By lorenceoforegon in forum GM Powertrain
    Replies: 0
    Last Post: 12-01-2009, 01:18 PM
  3. Egine runs rough while idling
    By Bear945 in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 09-12-2009, 03:21 PM
  4. 1999 Suburban 5.7 Runs Rough-need some help.
    By jtriplett in forum GM Powertrain
    Replies: 23
    Last Post: 08-04-2009, 09:07 AM
  5. Need help, engine won't idle, runs rough
    By rickyg1 in forum Performance & Fuel
    Replies: 23
    Last Post: 09-09-2007, 09:44 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •