GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 3 of 3
  1. #1

    Default 95 silverado turn signal problem

    I currently own a 95 k1500 and over the last six months have replaced the left rear turn signal backing plate (what the bulb plugs into) 3 times. Initially it intermittently works and burns out. I was thinking it was a short but this last week the other right side did the same. Any suggestions.
    Thanks,
    -Dave

  2. #2
    Legend

    Join Date
    Aug 2008
    Location
    East of Branson, Missouri
    Posts
    2,788
    Blog Entries
    14

    Default

    Dave-

    I would try to isolate what the problem is. Get a voltmeter/multimeter in there and check to see what's happening and at what voltage. Check for shorts by using a multimeter's continuity/resistance setting to see if maybe you can at least rule that out. Check for ground shorts/faults with every possible circumstance... turn, hazards, left turn only, right turn only, with parking lights on, etc etc. I would try every combination to see where the problem lies. Pay attention to voltage as well. You should be able to find your problem that way. Once you find the problem work your way back from it.

    Having a tow light harness? Check for frayed/burned/shorted wires. Fuses all still good? Check voltage there to see if it matches what you found out in back. Maybe it's time to get a new turn signal relay?

    Good luck,
    Steven



    "The Sarge"
    1999 Chevy Suburban LT- K2500
    7.4 454 Vortec, 4WD
    305/70/16 on Eagle Alloy




  3. #3

    Default

    thanks for the advice I'm going to takle it this weekend.

Similar Threads

  1. !983 Silverado 1/2 ton turn signal problem
    By bigbing64 in forum GM Electrical Tech
    Replies: 0
    Last Post: 06-02-2010, 02:03 PM
  2. Turn signal and brake problem
    By SPCMarty in forum Chevy C/K Truck Forum
    Replies: 0
    Last Post: 01-17-2010, 06:15 PM
  3. Turn Signal problem.. doesn't pulse..
    By Falcone in forum General Chevy & GM Tech Questions
    Replies: 4
    Last Post: 10-29-2009, 11:20 AM
  4. 04 Tahoe Turn Signal Problem - works 90% of the time
    By ycats in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 8
    Last Post: 08-24-2009, 01:33 AM
  5. turn signal problem
    By Stick in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 1
    Last Post: 06-22-2009, 07:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •