GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 8 of 8

Threaded View

  1. #1
    Jr. Mechanic blackburb's Avatar
    Join Date
    Nov 2008
    Location
    In Da U.P. of MI - - M Go Blue!
    Posts
    114

    Default Did I do something wrong??

    I put new shocks on my '94 Burb. Now it rattles every time I hit a bump. Where there bushings in the old shocks I needed to reuse? If I grab the upper part of the shock, I can twist it just enough to make a clacking sound as it hits the mounting bolt. What's wrong here? Shocks are Monroe Gas Magnum and they didn't include any hardware at all.

    Ok, I think I may have it figured out. Seems you need to really crank the mounting bolts hard enough to bend the bracket in on the shock. Then it doesn't rattle. Is this right?
    Last edited by blackburb; 09-18-2009 at 03:18 PM.

Similar Threads

  1. Could there be something wrong?
    By 1slols1 in forum Performance & Fuel
    Replies: 2
    Last Post: 11-30-2009, 05:58 PM
  2. How wrong was I?
    By Kady in forum GM Powertrain
    Replies: 29
    Last Post: 03-17-2009, 09:09 PM
  3. What could be wrong with my 4x4
    By mike54 in forum GM Powertrain
    Replies: 2
    Last Post: 12-22-2008, 08:41 PM
  4. wrong oil
    By billw in forum General Chevy & GM Tech Questions
    Replies: 3
    Last Post: 03-09-2008, 11:31 AM
  5. what am i doing wrong?
    By 89suburban350 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 3
    Last Post: 05-21-2007, 02:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •