GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1
    Jr. Apprentice SkiBurban's Avatar
    Join Date
    Sep 2008
    Location
    Northern California
    Posts
    13

    Default Hello - Oh, and a warm running problem

    Good Morning.
    My 1992 Suburban is giving me fits with its warm running problem. I have chased problems from bumper to bumper, but the symptoms continue.

    Some history; we purchased the 1992 K2500 7.4 Suburban with 190K miles on it, and it ran fine. It was parked for >6 months, while I had other irons in the fire.
    I took it to be smogged, and it passed with flying colors. The most significant mechanical problem at the time was an annoying shifting problem, were it felt like the transmission was getting no speed input. I chased that problem down, with a replacement wiring harness and computer solving that problem.

    I performed a standard tune-up; plugs, cap, rotor, wires, fuel filter, oil and filter change. Also, I changed the thermostat because it was stuck open.

    It started having a hesitation problem, where it felt like 2 cylinders were falling out, so I changed out the coil, and added an MSD ignition system. No change.

    I narrowed the symptoms down to being worse when warm, thinking maybe a lean-condition. I changed out the fuel pressure regulator and distributor pickup sensor, and the throttle position sensor. No change.

    Anyway, it's driving me crazy. I still haven't figured out the problem, and I'm tired of throwing parts at it. Should I head to the dealership? Any thoughts, and help would be GREATLY appreciated.

    Thank you,
    Paul
    2005 K1500 Suburban LT 50K miles - All Stock

    1992 K2500 Suburban 200K miles - Still Running:rofl:

  2. #2

  3. #3

    Default

    Welcome to the site...you might get more responses if you post in the tech section.

    Bobby - North Carolina
    2008 4x4 5.3L V8
    6" Suspension Lift and 1.5" Body Lift
    20x9 Ballistic Jesters w/35" Toyo Open Country MT's & 1.5" rear wheel spacers
    4:56 Yukon Gears
    Hypertech Speedometer Calibrator
    Baja style bed mount spare tire carrier
    Flowmaster 40 series dual exhaust
    Recon Smoked LED tails/3rd brake lights/black projectors w/switchback LED's in the corners
    N-Fab Nerf Steps
    K&N CAI
    No Fear Pedals
    Tint, Line-X bedliner, Window visors, Rear wheel well liners
    Painted front grill, bow ties and door badges, de-"lettered" tailgate
    Powder coated front and rear bumpers

  4. #4

    Default

    Welcome to the site!
    Scott

    ΜΟΛΩΝ ΛΑΒΕ

    '94 Chevy Suburban K1500
    3" exhaust w/ aero turbine non-baffled muffler
    CFM Technologies TB spacer
    CB w/ 44" whip antenna


  5. #5
    Legend

    Join Date
    Feb 2008
    Location
    Red Wing, Minnesota, United States
    Posts
    3,389

    Default

    Welcome to the site, try a MAP sensor, some cars also have an IAC and that can do the same thing, the IAC you can actually take apart and clean
    99 K1500 Suburban LT "THE BEAST"
    Hypertech III, K&N, true dual
    285/75/16
    ___________________________
    Jason

  6. #6

    Default

    Welcome to the site!
    Michael, 17, CA

    2005 Silverado - See my garage for my mod list
    :great:

  7. #7

    Default

    Welcome to the site!


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  8. #8
    Master Mechanic zubbiez's Avatar
    Join Date
    Feb 2009
    Location
    Eagle Mountain Utah
    Posts
    663

    Default

    wlcome to the site.........
    2000 Silverado Z71 Whipple Supercharger, JBA Headers,3" cat back Flowmaster Exhaust, Volant cai, Pioneer Preimer deck,Orion subwoofer,03 signal light mirrors,03 taililghts

  9. #9
    Master Mechanic
    Join Date
    Sep 2008
    Location
    Dallas, Texas
    Posts
    592
    Blog Entries
    1

    Default

    Welcome to the site
    Visit www.gmpartsclub.com for all your Chevy Parts needs. These are factory OEM GM Parts with full GM warranty (unless otherwise stated).

    Parts For: Buick / Cadillac / Chevrolet / GMC / Hummer / Oldsmobile / Pontiac / Saturn

    877-347-6220 (New Expanded Hours)
    Monday to Friday - 7 AM to 6 PM Central
    Saturday - 8 AM to 2 PM Central

  10. #10

    Default

    Welcome to the site!

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Running rich problem
    By ftms in forum Performance & Fuel
    Replies: 18
    Last: 06-07-2010, 02:38 PM
  2. Warm death at low rpm
    By KAHruzer in forum Chevy C/K Truck Forum
    Replies: 0
    Last: 04-12-2010, 06:25 PM
  3. running problem
    By Project1 in forum General Chevy & GM Tech Questions
    Replies: 6
    Last: 01-12-2010, 06:29 PM
  4. Running problem.....
    By bgmotorsports in forum GM Powertrain
    Replies: 9
    Last: 04-03-2009, 11:30 AM
  5. Part Time Running Problem?
    By Yuzilla in forum GM Powertrain
    Replies: 4
    Last: 12-31-2007, 03:50 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •