GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 11
  1. #1

    Default Service 4x4 Light On

    sometimes on startup, "serivce 4x4" message comes on in on-dash computer, and wont let me engage any 4x4 or 2wd, but goes off and wont come back on for a while. could it just be a sensor?

  2. #2
    Master Mechanic Darknesss23's Avatar
    Join Date
    Jun 2008
    Location
    Brookfield, Ct.
    Posts
    536

    Default

    What Year vehicle? I had the same issue in my 08 silv.... I took it to Danbury Chevy but they said they could not do anything about it since they could not replicate the issue... They said it could be improper use of the 4x4 system... they said you should always operate the vehicle in 2wd unless road(slippery, low traction) conditions call for the use of auto, 4H or 4L...

    2008 Chevrolet Silverado 1500 LTZ 5.3L EC/Std Bed 4x4 Flexfuel
    Full Metal Jacket Spray on Bed Liner
    Black Powder coat Diamond Plate Weatherguard Tool Box
    Corsa Performance Sport Exhaust System
    K&N Flat Panel OEM replacement Air Filter
    Bridgestone Dueler A/T Revo tires P275/55/R20
    Black Reflective pinstripe and VORTEC hood lettering
    Billet front bowtie
    Rear Bowtie Delete
    Blue strobe grille lights
    Blue strobe rear window lights
    Blue LED Mini Light bar in front Grille

  3. #3

    Default

    its an 04 silverado 1500 and i always have the 2wd on unless im plowing and whatnot.

  4. #4
    Master Mechanic Darknesss23's Avatar
    Join Date
    Jun 2008
    Location
    Brookfield, Ct.
    Posts
    536

    Default

    Quote Originally Posted by nlocho11 View Post
    its an 04 silverado 1500 and i always have the 2wd on unless im plowing and whatnot.

    I hear plowing does put a lot of stress on the 4WD.... I would have it checked by a Certified GM Mechanic just to be safe... what Part of CT you from?

  5. #5

    Default

    southern CT..East haddam...you?

  6. #6
    Master Mechanic Darknesss23's Avatar
    Join Date
    Jun 2008
    Location
    Brookfield, Ct.
    Posts
    536

    Default

    Western Ct, danbury area about 10 minutes from the NY border

  7. #7

    Default

    Quote Originally Posted by nlocho11 View Post
    sometimes on startup, "serivce 4x4" message comes on in on-dash computer, and wont let me engage any 4x4 or 2wd, but goes off and wont come back on for a while. could it just be a sensor?
    You may want to get it scanned for codes. It may have a code which can help pinpoint the problem. It may be a sensor or the switch itself. Have you ever serviced your transfer case? If not it's a good idea to do it every 30K . Keeping the fluid clean prevents fine metal particles from settling into sensors.
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  8. #8

    Default

    I had this problem w/ my "old" 2004 Silverado Z71. I replaced the switch and had no more problems. However, with that said, I remember doing some research on this back then and found that there are several situations that can cause the Service 4x4 light to come on. I would get the codes scanned like Jimmiee suggested.

    This is a VERY COMMON problem with the '99 - '06 trucks. Hopefully, your situation is one of the simple (cheaper!) ones!!
    Mark
    2007 Black Silverado LTZ Z71 4x4 Crew Cab, 5.3L, Airaid MIT and K&N Filter,
    Corsa Sport Exhaust, Rough Country 2" Leveling Kit, Removed Front Air Dam,
    N-Fab Steps, Line-X Bedliner, Truxedo LoPro QT, Carriage Works Billet Grill,
    18x9 Helo 835 Machined Black Rims, 285/65/18 Nitto Terra Grapplers
    Time to slow down on the mods! Running out of money:neutral:

  9. #9

    Default

    ok i got the codes scanned, when the light was off, because it hasn't been on for a while now and there were no error codes that came up. I have to get my plow serviced next week, new fluids and a new harness, so i'll have the mechanic there take a look as well.

  10. #10

    Default

    Quote Originally Posted by nlocho11 View Post
    ok i got the codes scanned, when the light was off, because it hasn't been on for a while now and there were no error codes that came up. I have to get my plow serviced next week, new fluids and a new harness, so i'll have the mechanic there take a look as well.
    A code reader won't "see" transfer case codes. If the lights were flashing you have or had a code. The code will be stored as a history code. The only codes a code reader will see are OBD Generic "P" codes.

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. Service Air Bag Light
    By JeffW in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 16
    Last: 12-03-2011, 02:47 PM
  2. Service 4wd Light
    By leadpan101 in forum GM Powertrain
    Replies: 17
    Last: 08-17-2009, 10:16 AM
  3. Service 4wd light
    By BillBoost37 in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 02-25-2009, 09:31 PM
  4. Service 4WD light. need help.
    By Tiny1987 in forum GM Powertrain
    Replies: 4
    Last: 02-10-2009, 04:25 PM
  5. 4wd service light...
    By Cros89 in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 9
    Last: 01-05-2009, 08:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •