GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 LastLast
Results 1 to 10 of 16
  1. #1

    Default tranny problems?

    My tranny hasn't given me one second of trouble. anyone had any problems?

  2. #2

  3. #3

    Default

    not a day of trouble with anything on either my old 2002 trailblazer or my new Envoy.

  4. #4
    Sr. Engineer Aeropagus's Avatar
    Join Date
    Jan 2005
    Location
    New Mexico
    Posts
    405
    Blog Entries
    1

    Default

    never had any problems with the tranny. Not a problem shifting, finding the gear, or anything.
    John ~ New Mexico ~ It's all about the bowtie!
    2007 GMC Envoy & 2010 GMC Sierra

  5. #5

    Default

    There were some "computer" and "electrical" problems with the 2002 tranny, but that's the only problem that I've ever heard about with the tranny.

    Mine is pretty solid, does a good job and hits the gears just right. No problems here.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  6. #6

    Default

    Only one problem. A leak which leaves tranny fluid on the frame rail on the drivers side where the driver would sit. I believe it is a seal, it only happens when the fluid get hot after highway trips. Anyone have some insite as to the cause. The dealer can't figure it out. They want to tear the thing apart and charge $4k. Other than that, the truck is great!

  7. #7

    Default

    Hah. Never heard of that. How much fluid are we talking about?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  8. #8

    Default

    depends on the trip. It looks like alot (pancake size x3), however when I check the level it is still in the hot range. Its just irritating to see the "spot" on the driveway. the fluid gets caught up oon the frame rail and transmission support and makes it look alot worse than it is. I've looked in the shop manual, and it says that a common problem is the speedo cable seal. Just a little rubber donut. Theres been a couple of cases noted but no one gives a response.

  9. #9

    Default

    Can you spot where the leak comes from?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  10. #10
    Sr. Engineer Aeropagus's Avatar
    Join Date
    Jan 2005
    Location
    New Mexico
    Posts
    405
    Blog Entries
    1

    Default

    yeah, that's where I would start. Can you see where it's leaking from?
    John ~ New Mexico ~ It's all about the bowtie!
    2007 GMC Envoy & 2010 GMC Sierra

Page 1 of 2 12 LastLast

Similar Threads

  1. Tranny problems
    By chevy305 in forum General Chevy & GM Tech Questions
    Replies: 1
    Last Post: 07-16-2010, 11:18 PM
  2. Need Help with Tranny problems !
    By treemanjw in forum GM Powertrain
    Replies: 4
    Last Post: 06-18-2010, 03:24 PM
  3. Tranny Problems
    By Larryuidiot in forum GM Powertrain
    Replies: 1
    Last Post: 01-19-2010, 05:03 AM
  4. 95 z71 tranny problems
    By orod88 in forum GM Powertrain
    Replies: 5
    Last Post: 06-01-2009, 06:19 PM
  5. Tranny Problems..Help!
    By 98 chevy in forum GM Powertrain
    Replies: 2
    Last Post: 05-10-2009, 09:21 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •