GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 6 of 6
  1. #1

    Default Electrical problem?

    I have a 2002 Trailblazer. For the past several months, the anti-lock brake light has stayed on sometimes. The local dealer said we needed a new anti-lock module (at a cost of $900+) but the problem appears to be electrical, not the anti-lock brake module. If the antilock light stays on, the heating/cooling fan does not work either. Starting the car before putting on seatbelts prevents the light from coming on - sometimes. It may go out after a few minutes of driving; other times it stays on for the whole trip. It is very frustrating. Anyone else had this problem?

  2. #2

    Default Electrical problem? - Trailblazer anti lock brake light

    Does this problem affect the anti-lock brakes? That is, do they still work? I'm not telling you to go out and slam on your brakes, but if you have needed to hit them hard in the recent past, did the anti-lock unit kick in? You'll know when the kick in.

    I've not heard of a problem like this before. Maybe someone else out there has?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    * I've been saying for years that I was going to change my username, and I finally did.

  3. #3

    Default Brakes

    I had a 99 suburban with the anti-lock brake kight staying on and mine was related to the abs sensors at the wheels sticking a tad, they just needed cleaned and adjusted. Make sure you do that first, much cheaper than the module. That also sounds really high for a module!

  4. #4
    Newbie
    Join Date
    Sep 2008
    Location
    Hopkinsville, Kentucky, United States
    Posts
    3

    Default

    Quote Originally Posted by terry0341 View Post
    I had a 99 suburban with the anti-lock brake kight staying on and mine was related to the abs sensors at the wheels sticking a tad, they just needed cleaned and adjusted. Make sure you do that first, much cheaper than the module. That also sounds really high for a module!
    I recently purchased a 97 K2500 4X4 the antilock light stays on constantly and I've also noticed a loud noise that happens just after stopping and placing the vehicle in park. I can only explain the noise as if you were to tap a hubcap with a mallet. Did your's have the same noise?
    Brent
    1997 GMC K2500 4X4 Suburban SLT
    1984 GMC C1500 4X2 Suburban High Sierra

  5. #5

    Default

    Quote Originally Posted by officegem View Post
    I have a 2002 Trailblazer. For the past several months, the anti-lock brake light has stayed on sometimes. It is very frustrating. Anyone else had this problem?
    My Truck has a similar problem. When I would come to a stop it would do the ABS grind. We put my buddy's $9K Snap-On computer on it and found nothing. Don't know if we looked everywhere though. We took the fuse out from under the hood and the ABS grind went away, but the ABS light stays on. Probably means the ABS doesn't work. I heard of a recall on the Wheel Hub Assembly for my truck but dealer said my truck wasn't on the recall list. I took it to the dealer and they found that I do in fact need 2 Wheel Hub Assembly's for it. They are 115 a piece with your own labor. Dealer wanted a grand to do it. Mark up on the part as well. The mechanic also said that with that recall, they would just clean it and it'd have a 50/50 chance on fixing the problem. My suggestion to you would be to check the fuse under the hood/replace it, or cleaning the Wheel Hub Assembly's.
    6" BDS Suspension Lift / 3" Body Lift / 38x15.50x20 Dick Cepek FCII on 20x12 Dick Cepek DC-1 (summer set) / 325/80/16 Dick Cepek FCII on 16x8 American Racing Diamond Back (winter set) / Hypertech Power Programmer III / Air Max Spiral Flow Air Intake / / 80mm Granetelli MAF / 80mm BBK Throttle Body / Helix Power Tower Plus Throttle Body Spacer / 2 Turbonators / Edelbrock Shorty Headers / 30 Series Flowmaster / 4.56 gears /

  6. #6

    Default

    Quote Originally Posted by bbforguson View Post
    I recently purchased a 97 K2500 4X4 the antilock light stays on constantly and I've also noticed a loud noise that happens just after stopping and placing the vehicle in park. I can only explain the noise as if you were to tap a hubcap with a mallet. Did your's have the same noise?
    That noise you heard is probably the ABS grind. I'd say it's the Wheel Hub Assembly's as well. Check your ABS fuse under the hood first.

Similar Threads

  1. Electrical Problem (need help)
    By 88Silverado in forum Chevy C/K Truck Forum
    Replies: 3
    Last: 06-15-2010, 10:12 AM
  2. Electrical Problem
    By bldawson89 in forum General Chevy & GM Tech Questions
    Replies: 10
    Last: 03-06-2010, 07:24 PM
  3. Electrical problem
    By '90_400 in forum Audio, Video & Gadget Tech
    Replies: 9
    Last: 12-08-2008, 08:53 AM
  4. Electrical problem - Please HELP!!!!
    By 540hp in forum Audio, Video & Gadget Tech
    Replies: 2
    Last: 09-27-2008, 04:24 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •