GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4

Hybrid View

  1. #1

    Default interesting condition

    ok so i just noticed that my burban will be running fine blowing hot air out of the heater and everything, then all the sudden it starts cooling down, so i glanced at the temp of the engine and it has shot up to 240ish it usually runs 190 area, so i keep looking at it then all the sudden it drops like a brick and the heater turns hot, what the hell? i was kinda thinking the thermostat what do you guys think?
    95 gmc k2500 sle 7.4L

  2. #2
    Jr. Apprentice reaper's Avatar
    Join Date
    Nov 2009
    Location
    Western Nebraska (almost Colorado)
    Posts
    17

    Default

    Thermostat is the area I would be looking. I have had the same prob with some of my older units. I have also seen this on my vette when the water pump started heading south.
    That which does not kill you...will only make you stronger!!!

  3. #3

    Default

    I'd think either a sticking thermostat, or a clog in the cooling system right around the heater core area. I'd suggest a new thermostat, and a cooling system flush. If you don't want to pay to have the flush done, I think I only paid about 20 or 30 bucks for a flush kit (guessing high I think) at the local parts store, & it just hooks up to your household garden hose spiget. You'd be AMAZED, or Grossed out at the things that a cooling system flush will spew out onto your driveway. I did an S-10 Blazer one time that looked like a cat coughing up a hairball big enough to make a complete wig for a long haired schnauser. I've got to admit it was one of the only times that working on a car actually turned my stomach. lmao.
    Jim
    1988 Chevy V-10 Suburban 4x4, 350 TBI, 33x12.50's
    1965 Chevy C-10 Pickup, 250 inline six, 3 on the tree.

  4. #4

    Default

    sorry i didnt follow up on this lol, anyways so i was thinking since i was going to replace the thermo anyways just to see if that was the reason i would change my belt, looked old, and right when i took the pressure off i sprang a leak from my water pump, took it off and wouldn't you know the only thing holding it tight was the belt, one bolt was totally rusted through and when i went to buy another one the split the old one open just to see and the propeller blade was half gone lol so i found my problem

Similar Threads

  1. Found this interesting!!
    By vncj96 in forum The Coffee Shop ~ Chit Chat
    Replies: 5
    Last: 10-05-2009, 08:29 AM
  2. interesting specs
    By kingofthehill in forum Lifted & Offroad Suspension
    Replies: 2
    Last: 04-20-2008, 12:47 PM
  3. Very Interesting...
    By Flatman in forum Performance & Fuel
    Replies: 0
    Last: 12-18-2007, 04:08 PM
  4. Old new's but interesting......
    By Grynder in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last: 07-16-2007, 02:29 PM
  5. Thought this was interesting...
    By moogvo in forum The Coffee Shop ~ Chit Chat
    Replies: 4
    Last: 03-15-2006, 04:42 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •