GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 1 of 2 12 Last Post byLast Post by
Results 1 to 10 of 18

Thread: New to forum

  1. #1

    Smile New to forum

    Hello all from near San Antonio Texas!

    I've put 128,000+ miles on my 1999 Chevy Suburban LT since I bought her in 2003. She's had several break downs but has never failed me on a long trip (every summer we head to Myrtle Beach, and she's also made trips to Minnesota, my home state).

    My mechanic and myself do a good job on fixing any problems. Right now I have a "Service Engine Soon" light with an associated code relating to the catalyic convertor. I have just put a K&N air filter on the rig. Would this cause this SES light??

    Talk at 'ya soon, DRG

  2. #2

    Default

    welcome to the site
    Rick

    83 CJ-7 (sbc)
    02 Tahoe

  3. #3

    Default

    Welcome to the site! How close to San Antonio do you live?


    2010 Z/71 Colorado C/C
    Black 4X4 w/5.3L V8
    ===============
    2007 Winnebago Adventurer
    w/8.1L Chevy & Allison 6spd.
    Canyon Lake, Texas

  4. #4
    Legend s5belford's Avatar
    Join Date
    Apr 2009
    Location
    Kalamazoo Michigan
    Posts
    1,456

    Default

    welcome to the site!


    S.BELFORD

    2009 Silverado LT1: All Star Edition
    5.3 Liter V8 4x4

    Factory:
    Locking Rear Differential
    3.73 Rear Axle
    Fog Lamps
    Factory Remote Start
    Locking Tailgate
    20" Wheels

    Aftermarket:
    Rear Wheel House Liners
    Molded Mud Flaps
    Stainless Nurf Bars
    Driver Information Center
    20% Tinted Windows
    Low Profile Diamond Plate Tool Box
    GM Bed Liner
    Silver Birch Metallic Mirror Covers
    Silver Birch Metallic Vent Visors
    Flowmaster Super 40 (knock off)
    20" Wheels
    Bed Rail Protectors
    Extang Tonneau Cover

  5. #5
    Legend
    TRPLXL2's Avatar
    Join Date
    Jan 2009
    Location
    Norwalk, Ohio
    Posts
    3,368
    Blog Entries
    8

    Default

    Welcome to the club!

    I have heard of K&N filters being over oiled, and causing the MAF sensor to mess up and throw a light or a code. But other than that I have no idea, and it would have to be physically dripping for that to happen.
    2004 Chevy Colorado
    LS1 5.7 swap/TBSS rear axle swap

  6. #6

    Default

    Welcome to the forum!!
    If you find yourself slipping,.....tie a knot.....hold on tight

    Black
    2008 silverado
    1500 crew cab
    5.3 L 4x4
    Borla exhaust, rbp black tip
    tint, bed liner
    2.25 in ready lift leveling kit
    18x9 rbp 94r
    33x12.5x18 toyo mts

  7. #7
    Legend
    Eddie Z71's Avatar
    Join Date
    Mar 2009
    Location
    Colorado Springs, CO
    Posts
    3,838
    Blog Entries
    1

    Default

    Hi, and welcome to the site!
    Eddie , 2000 Chevy Tahoe Z71 (old style)

  8. #8

    Default

    Welcome to the site!

    Bobby - North Carolina
    2008 4x4 5.3L V8
    6" Suspension Lift and 1.5" Body Lift
    20x9 Ballistic Jesters w/35" Toyo Open Country MT's & 1.5" rear wheel spacers
    4:56 Yukon Gears
    Hypertech Speedometer Calibrator
    Baja style bed mount spare tire carrier
    Flowmaster 40 series dual exhaust
    Recon Smoked LED tails/3rd brake lights/black projectors w/switchback LED's in the corners
    N-Fab Nerf Steps
    K&N CAI
    No Fear Pedals
    Tint, Line-X bedliner, Window visors, Rear wheel well liners
    Painted front grill, bow ties and door badges, de-"lettered" tailgate
    Powder coated front and rear bumpers

  9. #9

    Default Near San Antonio

    I live in the growing city of Cibolo. It's about 20 miles up the road from San Antonio.

  10. #10

    Default MAF dirty from air filter oil?

    Could I send a mist of SeaFoam thru the MAF to try and clean it up??

Page 1 of 2 12 Last Post byLast Post by

Similar Threads

  1. New to Forum
    By psmsmallengines in forum Member Introductions
    Replies: 10
    Last: 06-11-2009, 09:06 PM
  2. New to the forum
    By tblazer05 in forum Member Introductions
    Replies: 9
    Last: 03-10-2009, 11:13 AM
  3. New to the Forum
    By BhamWhitey in forum Member Introductions
    Replies: 11
    Last: 12-24-2008, 11:42 AM
  4. New to Forum
    By VrodderD in forum Member Introductions
    Replies: 6
    Last: 09-04-2007, 04:54 PM
  5. New to the Forum
    By tnvolsone in forum Member Introductions
    Replies: 4
    Last: 09-02-2007, 01:53 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •