GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 9 of 9
  1. #1

    Default anti lock brake probs

    when ever you hit the bakes to stop get below 5 mph and anti lock brakes kick in.. what is my problem? when you hit the break hard fells like it pulls the tire o5 silverado 4x4 ext v8 4 wheel disc brakes. got any advice for me??

  2. #2

    Default

    I got a 2003 chevy silverado reg cab 4.8 v8 4x4 and i got the same problem with my brakes. I dont know what the problem is but i really need to find out before I end up in a accident. Let me know if you figure out what the problem is and I will do the same. Thanks

  3. #3

    Default

    It's probably a bad sensor at one of the wheels.

    You'll need to have the abs system computer scanned at a repair shop to figure out which one.

  4. #4

    Default

    You have a wheel speed sensor that is dropping out at low speed and needs replaced

  5. #5
    Newbie
    Join Date
    Jan 2010
    Location
    Snohomish, Washington, USA
    Posts
    5

    Default

    i got an 03 yukon with the all wheel drive system and it does it too at low speeds as well as when starting off from a stop the traction control will freak out and pull power some times im pretty sure its a wheel speed sensor as wheel since they are used for both abs and traction control im gona look into it some more this weekend and let ya know

    - derrick

  6. #6

    Default

    I thought I read somewhere that there was a recall for late 90's- early 2000 trucks for" unintended low speed ABS activation"....my dealer sez that my year (2006) was not covered, called GM and asked if they were going to expand the recall, they said "no".....I wrote the NHSTB to report the problem to try and get a recall going....call GM, write the NHSTB and maybe this will be extended to later years.
    *Life should not be a journey to the grave with the intention of arriving safely in a pretty and well preserved body, but rather to skid in broadside, thoroughly used up, totally worn out, and loudly proclaiming - "WOW, What a ride!"

  7. #7
    Newbie
    Join Date
    Jan 2010
    Location
    Snohomish, Washington, USA
    Posts
    5

    Default

    so i just did a hub assem on my LF and the abs seems to be happy again... and no more traction control freakin out so ya i think that fixed it ill put a few more miles on it this week and see if it fixed it for sure
    -Derrick

    H.O.R.E. Racing
    Hanratty On/Off Road Enterprizes

  8. #8

    Default

    yes the abs wheel speed sensor i gues the are pron to rust and go bad
    thats the problem

  9. #9

    Default

    Its a wheel speed sensor. I ended up changing both hubs and sending GM the bill and they paid it. I got the recall after I changed them.

Similar Threads

  1. 03 04 silverado 1500 anti-lock brake part
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 05-11-2010, 10:10 AM
  2. 03 04 silverado 1500 anti-lock brake part
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 05-11-2010, 09:00 AM
  3. 99 00 01 02 silverado 1500 anti-lock brake part
    By Steve in forum Chevy Parts eBay
    Replies: 0
    Last Post: 01-10-2010, 12:10 AM
  4. Anti lock brake pulses at low speed
    By dslvolks in forum Lifted & Offroad Suspension
    Replies: 0
    Last Post: 07-31-2009, 02:24 PM
  5. Anti-Lock Brake problem, maybe?
    By pspreston in forum Chevy Silverado Forum (GMC Sierra)
    Replies: 4
    Last Post: 07-30-2008, 11:08 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •