GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14
  1. #11

    Default

    That only fixed 90% of the problem? Both tie rods?

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  2. #12

    Default

    Quote Originally Posted by Steve
    That only fixed 90% of the problem? Both tie rods?
    Yes, both tie rods .............. still clunks a little but the wandering problem seems to be greatly improved. Have come to the conclusion that it's simply not a good handling or steering
    truck ... follows the slightest irregularity in the road surface. Still have to "steer" it. Maybe the
    post 2002 models are better. Due for a trade but if the new ones don't steer any better than this one, doubt if I'd get another Envoy, or a Trailblazer even tho they're great looking trucks. Would like to hear from someone who has a newer model.

  3. #13

    Default

    My 2002 has a little bit of play. Maybe like 1 degree. However, the alignment is off, I think the wife must have hit something like a big pothole or something.

    Steve
    10 Chevy Traverse LT AWD
    02 Chevy Trailblazer LS (110K+ miles - loaded except for 4WD - WRECKED!)
    99 Chevy Cavalier LS (105K+ miles - commuter car)
    78 Chevy Suburban Silverado (454, 3/4 ton)
    62 GMC 3/4 ton Pickup (350 police interceptor)

    Remember: Search Before Posting | Fill out Your Profile & Signature
    Follow Us Please: facebook.com/gmtruckclub | twitter.com/gmtruckclub
    Support GMTC: Help the site, contribute today

  4. #14

    Default

    I have a 2003 Envoy and up until approximately a few weeks ago, the ride was really smooth, no problems. I only have 37,500 miles on my vehicle and I believe I have suspension problems as well. The ride is smooth as long as there are no bumps or potholes, or speed bumps to go over. It makes a loud noise and it sounds like the suspension bottoms out or something is shaking when you go over any little bumps. I brought it to one dealer about 4 days ago by appt and as of yesterday evening, they still had not even looked at my vehicle so I picked it up and am looking for another dealership to accomodate me.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. Replies: 0
    Last Post: 01-27-2010, 01:40 PM
  2. 96 Chevy tahoe problem fuel problem? Need help ASAP!
    By Fear58 in forum General Chevy & GM Tech Questions
    Replies: 5
    Last Post: 12-13-2009, 05:38 PM
  3. front suspension problem help!
    By CJlambertz71 in forum Lifted & Offroad Suspension
    Replies: 4
    Last Post: 01-17-2009, 09:37 AM
  4. Suspension Problem
    By silverado_TN in forum Lifted & Offroad Suspension
    Replies: 4
    Last Post: 11-17-2008, 11:08 PM
  5. suspension
    By dal in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 08-06-2005, 11:58 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •