GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 4 of 4
  1. #1

    Default Bucking under load

    I have a 97' K1500 w/230 K miles and is bucking like a bad miss at highway speeds under load such as going up a hill. The bucking seems to deminish if I back off the accelerator. The engine idles fine w/o roughness or miss symtoms even if I accelerate slowly. This maybe related to surging while accelerating from a standstill problem I've had for a while. Any ideas ? BTW - engine seems to accelerate much better when cold when it is probably in open loop control.

  2. #2
    Jr. Mechanic
    Join Date
    Dec 2008
    Location
    Gettysburg, Pa.
    Posts
    103

    Default bucking under load

    Have you checked for any codes, if you find a P0300 look for vacuum leaks and/or check out the intake gasket would probably be a good place to start, good luck.

  3. #3

    Default

    I would also check the ignition components. Is your check engine light on? If you do have a P0300-P0308 I would consider replacing the spark plugs, wires, cap and rotor.

  4. #4

    Default

    Quote Originally Posted by dsquared View Post
    I have a 97' K1500 w/230 K miles and is bucking like a bad miss at highway speeds under load such as going up a hill. The bucking seems to deminish if I back off the accelerator. The engine idles fine w/o roughness or miss symtoms even if I accelerate slowly. This maybe related to surging while accelerating from a standstill problem I've had for a while. Any ideas ? BTW - engine seems to accelerate much better when cold when it is probably in open loop control.
    You can take a spray bottle and wet down those plug wires,it sounds like a cracked spark plug or a arcing plug wire. Someone can brake torque the engine to simulate a load and observe any arcing from the wires.

Similar Threads

  1. bucking between 55-70 mph
    By dsquared in forum GM Powertrain
    Replies: 17
    Last Post: 06-01-2010, 02:55 PM
  2. gat a load of this
    By bob13 in forum Games Forum
    Replies: 19
    Last Post: 05-01-2010, 02:59 PM
  3. 05 GMC Yukon - Problems with 4x4?, Car is bucking in hairpin
    By JVS440 in forum Chevy Tahoe Forum (GMC Yukon, Cadillac Escalade)
    Replies: 4
    Last Post: 02-02-2007, 09:07 PM
  4. 05 GMC Yukon - Problems with 4x4?, Car is bucking in hairpin [Expired Topic]
    By JVS440 in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 9
    Last Post: 01-11-2007, 11:43 AM
  5. 05 GMC Yukon - Problems with 4x4?, Car is bucking in hairpin
    By JVS440 in forum The Coffee Shop ~ Chit Chat
    Replies: 1
    Last Post: 01-05-2007, 11:15 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •