GM Truck Club
THE PREMIER CHEVY TRUCK & SUV FORUM
Founded in 2004 ~ We're the #1 Chevy Truck & SUV Forum.
Silverado & Sierra | Tahoe & Yukon | Suburban & Yukon XL | SUV & CROSSOVER
Results 1 to 5 of 5
  1. #1

    Default Tranny jumps rpms when shifting

    I've got a 2004 Suburban with the 5.3 and for some reason when it shifts from 3rd to 4th and sometimes from 2nd to 3rd the rpm jumps during the shift like the clutch is slipping and then comes back to normal.
    Does anyone have any idea what the problem could be?
    Thank you in advance!

  2. #2

    Default

    Quote Originally Posted by bluestreak94 View Post
    I've got a 2004 Suburban with the 5.3 and for some reason when it shifts from 3rd to 4th and sometimes from 2nd to 3rd the rpm jumps during the shift like the clutch is slipping and then comes back to normal.
    Does anyone have any idea what the problem could be?
    Thank you in advance!
    Yes it's slipping. First check for trouble codes. Is it full of fluid? If so it's time to pull the pan and check the filter. Is the fluid burned?
    Jim

    2004 SILVERADO 2500HD LS
    Pro Comp Leveling Kit
    285-75-16 Cooper ST All Terrains
    Pro Comp Programmer
    Bilstein Shocks
    Linux Bed Liner
    Tinted Windows



    Other rides:

    1967 Landcruiser <350 Chevy>
    1970 Camaro
    1990 Geo Metro Convertible
    2007 FJ Cruiser

  3. #3
    Sr. Mechanic poncho08's Avatar
    Join Date
    Dec 2008
    Location
    where ever the pipeline takes me in canada
    Posts
    183
    Blog Entries
    1

    Default

    had same prob with my 08 this summer and it ended up being the shift solenoid
    08 LTZ 5.3L
    ext cab reg box
    ranch hand bumper
    74 gal slip tank in box
    magnaflow off the side in front of pass tire
    green preformance cold air intake
    airrade spacer
    bully dog tuner
    alpine nav deck JL10inch stealth sub and 350watt amp

  4. #4

    Default

    Quote Originally Posted by Jimmiee View Post
    Yes it's slipping. First check for trouble codes. Is it full of fluid? If so it's time to pull the pan and check the filter. Is the fluid burned?
    I have a small obd2 ( got it off ebay ) and the only thing it tells me is that the system is running lean. As for the fluid it's still somewhat red i've got about 90,000 miles on it.

  5. #5

    Default

    Quote Originally Posted by poncho08 View Post
    had same prob with my 08 this summer and it ended up being the shift solenoid
    Is the shift solenoid expensive? Or is it an easy fix. Please tell me it's an easy and inexpensive fix cause with four kids right before Christmas an expensive tranny prob is not a planned budge expense!!

Similar Threads

  1. Suburban Jumps Gear Cog
    By veralyne in forum GM Powertrain
    Replies: 0
    Last Post: 12-25-2009, 12:41 PM
  2. Oil Pressure gauge jumps around, settles to 0
    By Xtrempickup in forum Chevy C/K Truck Forum
    Replies: 5
    Last Post: 05-15-2009, 02:26 PM
  3. WOT=RPMs not going up
    By 98 chevy in forum GM Powertrain
    Replies: 8
    Last Post: 05-14-2009, 05:06 PM
  4. HELP 95 GMC jumps out of reverse gear
    By aussie453 in forum GM Powertrain
    Replies: 5
    Last Post: 01-09-2009, 05:15 AM
  5. Check gauges light on, tranny not shifting properly [Expired Topic]
    By Idahogroundhog in forum Chevy Suburban Forum (GMC Yukon XL)
    Replies: 8
    Last Post: 05-24-2006, 11:32 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •